Spark battery shield

About 3 weeks ago, I got my battery shield, plugged it in and it charged the battery. I tested it on a Spark and it worked so I put it aside. So today I pull it out, the battery is dead so I charge it with the shield and the DONE light comes on. When I try to plug it to a Spark, there is no power. I plugged the batter on a SeedStudio Lipo Rider Pro I have and it worked just fine powering the Spark. So the shield charges but does not power. That is the ultimate in power saving! What’s my next step?

1 Like

Hey @peekay123! Have a look over here :smile: Might be the fix?

Thanks BDub! Unfortunately I have the modified shield :frowning:

@peekay123 @BDub

Here is a excellent battery solution for the Spark Core.

I have tested these thoroughly and they work great and for the money they a really good deal. This what I have been running my Spark Core on for days straight.

They can be quickly recharged at 2 amps which is really nice.

This will run the spark core for about 80 hours

And they have larger versions also:

1 Like

RWB, I appreciate the info! However, it doesn’t fix my lemon shield. Frankly, I never liked the mustache and I am waiting for Mr. timb’s shield. :smile:

@peekay123 I’m waiting for Tim’s shield also but for now if you want to get the Spark Core away from the power outlet those batteries are the best deal I have found to date.

@peekay123 As a test, could you plug the battery and the USB cable together when you connect it to the Core and report what happens?

Mohit, when I plug everything in, the battery indicates its charging, the large chip on the shield gets HOT and the core does NOT power up.