Some problem this morning?

Earlier this morning (Sunday) I updated my code in a photon from the Web IDE with no problem. But now, none of my devices will even signal - the status board says no issues - but I wonder… anyone know or able to look at this today? I tried all the usual and have tried to signal 3 photons (reset each one first etc) but nothing happens… No network issues my end - can still access everything as before. Tried new browser instance - nothing changed.

Sorry, one thing I have noticed is that after reset the photons all go to breathing blue - but they all change to breathing green after about 10 seconds or so. Is that indicative of the problem?

Sounds more like a WiFi network issue…

If you have a Photon handy, place it in safe mode to see if it connects well.


Hi Kenneth,

I tried safe mode and sure enough I can signal the photon in that mode.

Not sure what to try now - there’s nothing else that I can’t do via the Wifi - everything else still works fine. I have restarted (power cycled the Wifi AP) just in case of a problem - but the photons (when in normal mode) still remain inaccessible for writing or signalling. Also, the Photons (when running normally) are still able to publish messages to the web console just fine - so if it is a Wifi issue it must be a fairly specialised one? Not sure what else to try.

You might have made changes to your firmware code that caused the WiFi connection to disconnect.

Try running a simple application like blinky and the devices should connecting fine. After that, you can debug your firmware and see what happened.


Hi Kenneth,

Well, that would seem to be it, in safe mode I can write blinky to the Photon no problem and it runs. So, all okay now - many thanks. Just go to go and find out what’s wrong with this code that’s not only crashing my Photon, but seemingly interfering with my WiFi functionality in some odd way!

P.S> Discovered the problem.

  1. My application includes code libraries to drive a 4D system touch screen. This was being use with Photon #1 - but due to making a frame for the screen I had disconnected the touch screen temporarily.
  2. I had mistakenly uploaded this same code into photon #2 - which is supposed to be running an LED Matrix clock program.
  3. I also tried uploading to photon #3 (in a different room) which I have since discovered was actually not powered up cos the USB supply for it has died.
  4. By experimentation I have just proved that, when the touch screen code is run without there being a touch screen connected, it crashes - but still seems to send some events to the cloud - odd!!!

So, with Photon 1 and 2 running the code that needed a touch screen connected, -
but with no touch screen connected - they both appeared unresponsive! Reconnected the touch screen to photon #1 and all okay again. Then, from safe mode re-flashed the clock program into photon #2 and now everyone is happy again.

So easy to get in these knots isn’t it!!?
Thanks Kenneth for your help with this.

Best regards
Alan T.