Photon used to work, uploaded bad program, now breathing magenta

Story begins with the Sparkfun Photon Dev kit. Somehow I got it working, running code, then I sent some genius program that disables wifi and basically made it unusable.
Meanwhile I’d gotten another Sparkfun Photon board (not the kit) and could not get it to work at all. Spent a long time with networking and routers and I’m pretty sure I got it right, I can reliably load Blink to the new board. Super!
Since my network seems better now I’m trying to get the bricked Photon Dev board running again. For some reason it’s gone from Particle Build:Devices, only my second board is there.

So here’s the CLI dance, starting in blue blink mode:

  • photon detected on USB, finds Photon-2ppe" on wifi
  • obtained magical secure claim code
  • I am unable to automatically connect to Wi-Fi networks (-___-)
  • maunal, connect to it’s network
  • it finds my network ok, enter password…
  • Configuration complete! You’ve just won the internet!
  • internet back on
  • It doesn’t look like your Photon has made it to the cloud yet. board is breathing green

Restart everything, blinking blue. There’s two Android apps, I don’t know what the difference is but I stick with Particle.

  • choose your photon, fine
  • tablet connects to it’s net
  • “this photon is owned by another user, change owner to” (my particle account). I hit Change
  • home network shows up, enter pw
  • config wifi creds, connect to wifi net, waiting for device cloud connection, breathing green
  • error setup process couldn’t configure the wifi credential for photon.

I used to have better luck entering the wrong network password (i know…) and it would get to cloud verify and fail there.

Bottom line when I reset Photon it breathes pink and I wonder what to do next. I have DFU util but haven’t tried that. Thanks for any help.

Breathing magenta you mean? https://docs.particle.io/guide/getting-started/modes/photon/#safe-mode

That’s a good sign. You should be able to see it in your device list using particle list

Try flashing tinker to it with particle flash DEVICE_NAME tinker

2 Likes

If your device breathes magenta (or pink as you say) it’s gone into Safe Mode and it has made it to the cloud.

But the reason why this happens could be that your board has an old system firmware on it and the code you try to flash was built for a newer version.

So normally when you leave your device in this state for 10 or so minutes the so called “Safe Mode Healer” should detect this and auto update your board (unless you interrupted that several times, telling it to not bother anymore).

You can always do a manual update via CLI.

npm install -g particle-cli
// or if you already have CLI installed, update it with
npm update -g particle-cli
// now put your device into DFU Mode and run
particle update
particle flash --usb tinker

BTW: The Android Spark Tinker App works for the Spark Core (based on the TI CC3000 WiFi chip) and the Particle App works for the Broadcom based devices (for the setup procedure this is - Tinker is the same).


Edit: Typed too long so @kennethlimcp got there first :wink:

2 Likes

Thanks for the replies all. A little update -
Had to go vote, got back and went at the firmware. I did do

npm update -g particle-cli && particle update

and tried adding it again, it behaved the same.
There is only my other photon when I do “particle list”.
So I downloaded photon firmware and followed the instructions at the Github.
(here) https://github.com/spark/firmware/releases/tag/v0.4.9-rc.3
used dfu for the two files. Now it blinks yellow and does not seem to come out of that. Tried factory reset and it still goes to yellow. Is that stuck in firmware mode?

I was trying all that while the replies came in, and I missed them, sorry!

Blinking Yellow is DFU mode, nothing wrong with that.
A factory reset DOESN’T EXIST on Photons, so there’s not much of a chance you actually did that.

That said, I see that you missed this part:
particle flash --usb tinker
Try the particle update followed by the above again, and let us know what happens.

1 Like

Hence my suggestion :wink:

2 Likes

Thanks for bearing with me all. I re-ran the update, sent Tinker, and after that it got right onto wifi and my list of devices.
I have won the internet, I got a blue blinkin’ led, now to start building things and getting into the real problems.
All in, these are amazing gadgets.

3 Likes