Breathe Cyan, Breathe Green - rinse & repeat!

Hi all,

Having issues on both my Core and Photon. They pretty much refuse to connect to the wifi. I have used particle setup many times, dfu-util to reset to tinker and particle update… but I just seem to get “breathing cyan, breathing green” in a loop.

I have tried 3 different APs. With and without WPA2. Set my phone up as a hotspot. Different people’s houses to see if it’s my wifi!!

Is there a way to completely and utterly do a factory reset as these devices worked fine for a few weeks, but nothing is seeming to work and I can’t even flash any new code to them as they won’t connect for long enough!

Thanks, Neil.

Breathing green doesn’t usually mean you have a Wi-Fi problem - it means something in your code (or a library you used) is preventing the cloud connection from working. This would also prevent over-the-air OTA cloud flashing.

Since you have the CLI installed, the easiest way to determine if this is the case is to put the device in DFU mode by pressing RESET and SETUP at the same time, releasing RESET and holding down SETUP still while it blinks magenta until it blinks yellow, then release. Then use the CLI command:

particle flash --usb tinker

If the tinker firmware is able to run without going to breathing green, you’ve found the culprit.

Alternatively, do a factory reset on the Core, and Safe mode on the Photons :slight_smile:

I have a related issue (I think): when I reset my Photon at work, I get fast blinking green, then, for about 15 seconds, breathing cyan, then it starts to breathe green.

My theory is that my networking guy has done something to the network, but I thought I’d see if something has happened on the side of things. Or, it might be something else … any ideas/debugging tips would be appreciated!

How does it behave in Safe mode?

I don’t know, I will find out.

So I put it into Safe Mode … then realised I had no idea what to do when it was in safe mode :grin:. A little research later, I launched Particle Dev, selected the errant Photon in question, flashed code to it, and then it started working again. I do know that when I’d been working at home, I inadvertently did flash my office Photon, and perhaps that triggered the issue.

Anyways, thanks again, Moors7!

Your one of the lucky ones!

I do consider myself lucky … in the sense that everyone on this forum seems to be a) knowledgeable, and b) generously willing to share.

1 Like