Can't get into Setup Mode or cyan breathing - only flashing green

Hi all,

I’ve spent the last 3/4 days trying to get my Photon up - desperate for help.
I did initially manage to get it to connect to my android, and register online, had it breathing cyan at one point and was able to enter setup (blue flashing).
After some problems flashing via the dashboard (it went magenta, but never seemed to work after that - needed a reset). I’ve flashed (using DFU as this is the only way I have of talking to the device) every firmware from 0.4.3 - 0.4.6 including tinker.
Still I’m unable to get into setup mode. If I hold setup until its flashing anything other than yellow and release, its back to flashing green.
I can’t setup using particle cli as it shows as offline, and can’t get it into setup for particle to connect via usb.
I’ve tried resetting the keys as well. Any ideas?
If I try particle flash —usb I get the following error (DFU works OK, bombs out after part 2 but I understand this is normal):
Error writing firmware…Cannot open DFU device 2b04:d006

thanks,

Paul.

If you mean Listening Mode (blinking blue) when you say Setup Mode, then there might be a misunderstanding

If you saw yellow, you have held the SETUP button and tapped RESET, but for Listening Mode you need to have the Photon running and then press and hold SETUP till it starts flashing blue.
If this doesn’t work from steady green, try to go into Safe Mode and then try the above.

BTW: Particle CLI also works via USB when in Listening and DFU mode.

Try this

npm update -g particle-cli
particle flash --usb tinker
particle flash --usb <firmware-part1>
particle flash --usb <firmware-part2>
particle flash --usb tinker

You don’t need to flash older system firmware in order to upgrade, you can just go for the most recent.
If you desperately want to downgrade, you need to flash part2 before part1.

tried holding setup - it just cyles through the colours (below).

if I follow the safe mode procedure, I still end up flashing green.
from there if I hold the setup button it cycles through the same sequence:
flashing magenta
flashing yellow
flashing green
flashing white
if I release setup at any of these phases it returns to flashing green. At no point do I get a blue or breathing cyan.
the particle flash commands with --usb do not work in any of these modes…

@clucks if you can get your Photon to stay in DFU mode, please run this command to capture your DCT region so we can analyze it:
dfu-util -d 2b04:d006 -a 0 -s 0x8004000:0x8000 -U clucks_photon_dct.bin you can email it to my first name at particle dot io.

Do you have the ST-Link V2 or any other way to connect to your Photon via JTAG?

@clucks thanks for the DCT binary. It definitely looks like you have a corrupted DCT (first one I’ve personally seen). If you can retrace your steps that you thought got you to this point, that would be super helpful. In particular, what steps you took from after the photon was connected to the cloud and the first time you noticed the continuous blinking green.

If you do not have a JTAG programmer, we can get a replacement Photon sent to you… please email hello@particle.io with a reference to this thread. If you do have a way to do JTAG programming we should be able to get you sorted quicker. Thanks!

I have 2 units; one is exactly the same… wow… bad luck.
I will check the second… hope it will work.

Valentin

The first unit is back! Thanks to Particle community! Yes…!

Valentin

2 Likes