Can no longer get into "setup mode"

Hi, I am currently stuck with the photon pulsing cyan. I am no longer able to flash new code to the device or enter setup mode by holding down the setup button (doing this makes freezes the led in the cyan state).

I also tried the following which resulted in an error Flash device failed [object Object]

flash ssgbutton system-part1-0.4.4-photon.bin

Any help regarding this issue? It has happened to 2 of my devices now.

Regards,
Kyle

Hold Setup, press reset. Release setup when its blinking yellow (safe mode). Then, with the CLI, try particle update.
After that, put it in listening mode again, and try particle flash --usb tinker.

Give it a shot, and let me know if that worked for you?

Brilliant, that did the trick - thanks!

One thing to note about this is that particle flash didn’t actually work, I got the following:

Error writing firmware…dfu-util: Invalid DFU suffix signature

However this step was still necessary before I could enter setup mode. This fixed both my devices.

It did work, that error is a known issue with DFU-util, prior to that line it has reported 100% succes :wink:

Glad to hear everything is working properly again :smile: