[SOLVED]Unable to flash new programs on my Spark core

Hi there,
sorry to open a new thread but from my search I didn’t find any suggestion for my issue.
I was enjoying with my core up to yesterday night, I have a basic breadboard setup (core + BMP180 + DHT22) and I am doing some tests… serial communication OK, sending values to an external website OK, showing the values on a local webpage OK . This was the last firmware I flashed yesterday night.

Today I wanted to try to upload data to ubidots, with this example: example but the core didn’t receive the firmware, even if compiler says OK. (so just breathing cyan, no magenta at all)
Opening the serial port I see that on the core there was the last firmware from yesterday (showing the values on a local webpage)

I restarted my PC, plug/unplug/replug the core, but nothing changed
So I tried one of the previous firmwares which were working, but nothing changed, still the same firmware is on the core.

I also tried to flash the blink_led example, but no magenta and no flashing, still the same firmware is there!

how can I get out from this loop?

thanks to everybody who can help!

Could you give a factory reset a try? This will take it back to the original Tinker firmware, after which you should be able to use it again. It will however require you to reconfigure WiFi settings. If you’re using the Spark CLI you can do this in DFU mode without the need to reconfigure credentials.
Let me know if this worked out for you.

1 Like

hi @Moors7 , and thanks a lot for your fast reply!
I thought about the factory reset, I still didn’t try this way because at the beginning I had a lot of issues with my core, as described in this post: post , having also to reinstall the firmware via usb and some other issues… which I would love to avoid redoing again :smile:

do you think that if I perform a factory reset I have to redo all what I did in the past ?

[edit] I also disconnected and reconnected the core from my wifi and the cloud, but when I open my serialport I get always the same output… the one from yesterday ! (showing the values on a local webpage)


lavori con l’IDE web o locale ?


Normally a factory reset shouldn’t hurt. But since you mention you’ve had to use the CLI before; have you still got it installed? If so, then you could try to flash a new app using that, which is also much faster. Documentation on how to use it can be found here: http://docs.spark.io/cli/#running-from-source-advanced-spark-flash
You can download the compiled .bin file from the Spark Build page, if you click the little cloud button next to the app name:

You should then be able to use the command spark flash --usb firmware.bin if you’ve opened the CLI in the same directory as your .bin file and DFU-util files.

@duffo64 Would you mind sticking to English, so everyone can follow along? Thanks in advance!

1 Like

@duffo64 web IDE, ma ho installato la Spark CLI
(for other readers: I was asked if I work locally or with the webIDE, and I use this latter, even if I have installed the Spark CLI)

Yes, sorry. Asking because at times my cores were unresponsive (mostly because of coding errors), but working through sparkulator I solved quickly keeping both buttons pressed, releasing reset (keeping mode pressed), release mode when led flashes white, and waiting until core flashes blue.
Then giving only wifi credentials again, core is clean.

Thanks, my Italian doesn’t go much further than “pizza” and “lasagna” :stuck_out_tongue:
The process you decribe would be the above-mentioned factory reset :wink: Using the CLI might be nicer for this since it’ll allow you to overwrite your currently problematic firmware without the need to reconfigure WiFi, but both solutions should normally work.

at the end… the unwanted factory reset did the trick :smiley: !
I messed you something while putting in DFU mode the core, so I choose/needed to try out the factory reset. Now the core is accepting firmware as normal!
thanks @Moors7 and @duffo64 for the fast and useful replies!


Glad I could help. I’ll mark this as [SOLVED] but feel free to post here again if these issues return.