[Solved] Unable to compile anything with workbench: main: No such file or directory

I am trying to test out workbench, but unfortunately I’m not able to get anything to compile. I have looked through the forum to make sure that I have no spaces in the folder name and that I am targeting the right device.

When I trying to compile the default .ino file in a new project, I get the following error:

> Executing task: make -f 'C:\Users\Rob\.particle\toolchains\buildscripts\1.5.0\Makefile' compile-user -s <

/bin/sh: line 0: cd: C:/Users/Rob/.particle/toolchains/deviceOS/1.0.1/firmware-1.0.1/main: No such file or directory
make: *** [C:\Users\Rob\.particle\toolchains\buildscripts\1.5.0\Makefile:42: compile-user] Error 1
The terminal process terminated with exit code: 2

I am, however, able to install libraries and launch the CLI.

Any idea what problem is? I have tried creating multiple projects, but each time have the same error.

Have you seen this post?

Maybe the steps outlined in there will help :crossed_fingers:


Thank you so much for the suggestion. I tried the steps in that post, but every time I opened Workbench (any projects), it would tell me the toolchain was dirty. When I tried to clean it, it would hang.

However, after seeing the issue you pointed out in the post, I decided to uninstall and reinstall the extension. Doing fixed the errors!

1 Like