[Solved]- Spark-setup-ios: "Organization not found"


I just created a product in the particle console. I now want to use the device-setup-library for iOS. I set the organization-property of the SparkSetupCustomization instance to true. For the organizationSlug und productSlug I used the four digit productId.

When I try to create a new account in my app, I get the following error:

Error signing up: Request failed: not found (404)

! signupWithCustomer /v1/orgs/2195/customers Failed (status code 404): 
    error = "Organization not found.";
    ok = 0;

What am I doing wrong?


I solved it by updating the SparkSDK to version 0.6.0

1 Like

Good to hear, thanks for posting the resolution.

Yes, in SDK 0.6 - I’ll be publishing an official update soon that you only have to set productID number in the SDK settings as org-slug and organizations were deprecated. I haven’t yet pushed it to Cocoapods as official release but glad to hear you could use it right of the master branch in the SDK repo.