[SOLVED]Server Timeouts

I have spent most of this Saturday trying to Flash a new program to one of my photons.
I get timeout error continuously. I got Tinker to flash once. But any other known good program times out. Even just trying to verify just waits for a long time and then goes back to ready.
I think you probably need to replace that old 386 server:>)

Really though if this is the state of affairs, then how can anyone develop on photon?

Seems to be working just fine for me in the Netherlands. Could it be that your internet is flaky?

Hi @rcomeau,

Hmm, can you try compiling a different program or checking your filenames / targeted devices? Can you tell us more about what you’re seeing? We actually just added extra capacity yesterday to the build farm, and I don’t see any delays at all.


I have several programs that worked fine in the past, but today, not so much. files seem to save fine, but verify, and flash keep timing out. you really need a log scroll so we can check back on error messages. Verify (most of the time) just sits for maybe 60-80 seconds the goes to ready with no indication that it compiled. (no little (1)).

reset both my routers, did a speed test (45Mbs). Three photons online.
Flashing code…if it does not flash magenta, verify your code and try again.The request seems to take longer than usual. Please be patient…
The request seems to take longer than usual. Please be patient…
The server has failed to process the request on time. Please try again.

Hi @rcomeau,

Hmm, any chance you could send me the device ID for the device you’re targeting? Sorry if it’s timing out. Just as a sanity check, can you try clearing the cache / token in the build IDE, and refreshing the page?


device ID: 250029001847343338333633

but I have tried 3 different devices, and 3 or different programs that worked yesterday.

How do I clear the cache/token in the build IDE?

cleared the cache, no help

Well I found the problem! Restarted windows (win 10) and the problem went away!


Out of curiosity, which web browser were you using?

It seems strange that a reboot of the local computer would solve something that seems to be broken on the server side. It may be that something in Windows or anti-virus or something that was causing any async (AJAX, web sockets, SSE, etc) to fail.

If it works, it works. Just something to keep in the back of our minds.

chrome, avast

Thanks for posting the solution, I was very confused on that one! :slight_smile:


me too!