[SOLVED] Rpi particle-agent kills i2c interface

After encountering issues with an existing i2c program I carried out the following steps to verify the problem:

  1. Fresh install of Raspbian Jessie 2016-09-23
  2. Enable i2c using raspi-config
  3. Install i2c tools
  4. Executed sudo i2cdetect -y 1 my i2c device is correctly detected
  5. Install particle-agent bash <( curl -sL https://particle.io/install-pi )
  6. Executed sudo i2cdetect -y 1 runs very slowly and my device is not detected

Stopping the particle-agent makes no difference.

particle-agent version: 0.2.0
Hardware: Raspberry Pi 2 Model B

1 Like

Thanks for reporting this. The particle installer doesn’t try changing settings for I2C automatically so I’m not sure what’s going on. I didn’t know about the i2cdetect tool, I’ll try it on my side too. I’m out for the Thanksgiving holiday. I’ll be able to investigate when I’m back.

1 Like

I have two pi3’s and the same thing is happening to me. i2cdetect takes several minutes to scan the buss anddoes not detect my sensor. :frowning:

We’re tracking issues with I2C on Raspberry Pi here:

I2C has not been implemented yet. It’s there now. See the changelog for instructions to update and make sure to reboot after updating the agent to reset the pins to a known good state.

@jvanier Thanks for the quick response in fixing this. After updating to latest agent and rebooting, I can confirm that i2cdetect now works as expected and my python script which uses i2c can now obtain reading from my sensor.

1 Like