Error 500 when trying to flash Raspberry Pi 3

Last night, I loaded the upgraded raspbian, loaded the particle-agent and all worked as it should. Tinker and flash LED etc.

I enabled I2C, and everything came to a stop, if I try to flash firmware to flash LED I get an Error 500.

I setup another SD card, I did get Tinker to work but still can’t get the Flash LED firmware to load (Error 500).

I have tried new SD cards with updated and upgraded Raspbian and particle-agent, with only ssh enabled, but still can’t get anywhere. Guess I will need to wait until @jvanier gets back, unless someone else knows the solution to this problem.

Other people have problems with I2C. I’ll investigate this week and post and update to the Raspberry Pi changelog

Created an issue in GitHub for this one so that we can continue the discussion and track the fix, if necessary.

I2C support had not been added yet. It’s now in there. If you want to try again, see the changelog for instructions and make sure you reboot after updating the agent to reset pins to a known good state.