[SOLVED] Photon with bad public key after Norwegian Blue bootloader reflash


#1

I’ve been experimenting with an external watchdog. I inadvertently was doing a FOTA update and the watchdog reset, subsequently bricking the photon. I ran the Norwegian Blue to bring the bricked photon to life, and everything is up to snuff except being able to connect to the Particle Cloud.

I’ve tried multiple times and ways to set WiFi credentials, but after watching the LED a bit closer it flashes cyan rapidly, then blinks red once, then repeats. It goes through several cycles like this and then reverts back to a cyan blink mode. From what I found in the Guide, this indicates a bad public key? https://docs.particle.io/guide/getting-started/modes/photon/#bad-public-key.

I have tried >particle keys server to no avail, and I’ve unclaimed this device from the cloud and attempted to reclaim with >particle setup

Out of ideas… hope the swarm collective can assist… thanks in advance.


#2

Attempted >particle keys doctor

CLI is puking with OpenSSL error:
_Error creating keys… Error: Command failed: openssl genrsa -out rsa_new.pem 1024

CLI v1.24.1

Update: looking for decent OpenSSL install steps
Added path variable to OpenSSL binaries