[SOLVED]Particle Dev Window not like Docs

I’m not sure what’s going on with my Particle Dev. It doesn’t look anything like what you show in the docs. This is what I’m seeing.

You’ve somehow managed to open the developer tools, which in turn opened the Mobile view. Try clicking the small grey cross at the top right, and all should be well :smile:

When I do that, I get an empty white window.

@Ric, if you want to keep the dev tools open, you can click on the mobile icon to the left of the “Elements” tab to turn the mobile preview off. When you do that, you will get the normal view.

That turns the left pane into a blank white window, with the right pane looking the same as in the image I posted. I still can’t get anything that looks like what I see in the docs.

Try clicking view - developer - toggle developer tools, then view - reload?

Or try Firefox :stuck_out_tongue:

This is the downloadable Particle Dev, not the Web IDE. Changing browsers won’t help I’m afraid…

1 Like

Where do I find “view”? I don’t see that choice.

On Windows it’s in the left upper corner of the program. On a Mac, not so sure. Haven’t you guys got one of those bars at the top of the screen with the program’s options?

Oops… N/m

1 Like

Yes, but the only thing on the bar is “Particle Dev”. I don’t have any of those other menus.

Then I think I’ll have to hand you over to someone with a Mac, @kennethlimcp, @peekay123?
Have you tried restarting it (might seem a bit obvious, but you never know…)? Reinstalling might also work, although that seems a bit harsh.

Already tried reinstalling. I deleted the app all together, downloaded a new one, and clicked on the Particle Dev.app icon, and what I get is what I showed in my first post. Thanks for your help.


I don’t have it installed but what’s on the top menu bar?

My editor is this:

It just has “Particle Dev”. That’s all.

Ok i see that there is a “cancel” button at the top left just below the close icon. Can you click that?

I don’t see any cancel button.

Do I need to have something else installed for this to work? I have that red “x” in the upper right, and red text in the console that looks like an error message. I haven’t done anything, other than download the app, drag the app icon into my applications folder, and then clicked on that icon.

There’s shouldn’t be since it’s a Mac App itself.

Just wonder which version of MAC OSx are you on and i guess you downloaded v0.0.24?