[SOLVED]Help! Updates not actually updating

Hey, I have been away from my project and Particle/Photon for a while and I was trying to update my project to the new system firmware, which I thought was just a matter of recompiling and uploading my firmware. However, it doesn’t change anything that I can tell. It uploads something to my Photon, just not the latest code :-/

Any ideas? Am I wrong in my assumption? How can I fix this?

What IDE are you using?
If you use Particle Build, check your target firmware setting in the Devices Drawer.
If you are not, try flashing a dummy sketch with the latest firmware targeted and let the device flash and reboot at least three times.

Or if you got CLI installed, perform an explicit update with particle update (after you’ve updated CLI to the latest version ;-))

I’m using Particle Dev

Particle Dev does not trigger an auto-update.

The easiest way then whould be to flash a dummy sketch (like “Blink a LED”) from Web IDE (Particle Build) to trigger update.

I flashed it with “Blink a LED” but now when I upload from Dev it just reflashes it with “Blink a LED”

Looks like I had an old version (0.0.24) of Dev that wouldn’t updated to the current version so I’ve reinstalled Dev

That fixed it!