[SOLVED] Failed to Flash : Permission Denied

Hello, I am trying to flash my Tracker One using Particle Workbench.

The flash fails and permission is denied. Everything up until the flash step was OK.

I had been following the instructions from the manual so I’m not sure what went wrong.

I was curious if other folks had seen this kind of error before.

looks like the docs are inaccurate, the Workbench command to run is called Particle: Flash application & DeviceOS (local) - more info over here:



Thanks @m_m

That worked! I will say the flash takes a lot longer than I expected, so for those of you experiencing this, just be patient, it should go through (it took > 5 mins for me, which seems very long).

In my experience under Windows a project build takes about twice as long as under Linux.
I’m now using Win10’s Windows Subsystem for Linux (WSL2) for building.


Thanks @ScruffR!

Thank you for the comparison! I am using OSX, so maybe close to Linux ¯_(ツ)_/¯

BONUS Question:
I am just starting to use the Particle Workbench after using Particle Dev. I remember build times taking 20 seconds in Particle Dev for the Electron. Is there something different in how it compiles in Workbench which causes this difference in time?


The biggest difference between the two is that Particle Dev never actually built locally but still used the cloud build (which you could still use with Workbench - just not for the Asset Tracker Firmware (yet)).
And you also only were able to build the application firmware where Workbench’s Particle: Flash application and DeviceOS (local) builds both the application and the device OS which is multiple times heavier that the application alone.


These assumptions are incorrect. The technical reason flashing a Tracker One is not allowed is because by default, when setting it up through setup.particle.io, it forces you to select or create a Particle Product. In doing so, the device is not ‘also’ added as a personal device, it only exists as a Product device, and is why the ‘permission’ to flash it is denied.

You can correct for this shortcoming by going to a CMD prompt and running the following command:
particle device add (long-particle-id)

You’ll find your newly added Tracker One device, as well as your other cloud flashable devices, by visiting the https://console.particle.io/devices page. Only the devices on that page are cloud flashable using Particle Dev and Workbench.

This is the same list of devices available when calling:
particle list

It would be great it if Particle could add another selection for "Personal’, ‘Development’ or ‘None’/‘No Product’ on the product selection screen when setting up Tracker One devices.

Thanks for the extra info @SmartAlex! Yeah there is clearly a lot happening behind the scenes.