[Solved]- Electron unable to handshake when plugged into breadboard

Hi there. I have a very strange problem using my Electron board when plugged into the breadboard. When I run my Electron board standalone (not plugged into the breadboard) then it handshakes with the server and sends message absolutely fine. If I plug it into the breadboard it is not able to contact the server (can’t get to the internet or can’t handshake), i.e. lots of cyan flashes and then two or more red flashes. If I then unplug it from the breadboard it works fine.

Nothing else is plugged into the breadboard.

I have the battery connected in all cases.

I am using the SIM that came in the package with the Electron board, it is inserted correctly and my data limit has not been reached.

I’ve peeled the back off the breadboard and buzzed-out all the tracks to confirm that no adjacent tracks (side by side or across the central divide) are connected to each other.

Signal strength here is good (-69 dBm as measured by the board itself). I have a video of this behaviour, if anyone wants to see proof, but it is a 20 Mbyte file.

Wassup!? Stray capacitance perhaps?


I’ve read of other people having similar issues, but I never had.
Is your antenna plugged in properly.
Does it make a difference where on the breadboard you got your device?
I usually have the antenna side at the edge of the breadboard.

I’ve tried various positions on the breadboard: left, right and middle. I think I have seen the same thing when I have the Electron not plugged into the breadboard but instead have some flying leads attached, though it is much more rare in those cases.

Antenna seems to be plugged in well; I’ve tried un-plugging and re-plugging it and various orientations of the antenna connector body to the board.

Do you happen to know whether any of the other cases were resolved or worked-around in the end?

Nope, the few cases that reported the issue were intending to put it on a custom PCB so they never put too much effort into it.

I have ordered two more Electrons so once they make the journey through customs to me I’ll have a go with one of them. Thanks very much for your help.

1 Like

Hello, did you find out anything? I experience similar issues (stays blinking green). On my setup the error is not very consistent; most of the time Electron mounted on breadboard is unable to connect, sometimes it is. I tried couple of different breadboards. Without breadboard works every time. I have nothing connected on the breadboard, wonder could the board collect some electromagnetic interference that the electron reacts to…?


I got my electron today and I can confirm that I have exactly the same issue. It breaths cyan fine when not connected to breadboard. But when I connect to breadboard it doesn’t connect. The led flashing cycle is

  • Short slow blinking cyan
  • Followed by long rapid blinking cyan
  • Followed by short rapid red blinking

It keeps looping this sequence endlessly. I did some playing around and here is the further insight. I connect device and when its breathing cyan I mount it on breadboard. It keeps breathing cyan this way. If I restart now it will get stuck in the loop mentioned above. If I don’t then it keeps breathing cyan while on the breadboard. Now here comes the interesting part, as the device is breathing cyan on breadboard, if at this moment I call a function of my firmware app (either from CLI or another web app) it goes back to the endless connecting… loop.

Calling function when device is not on breadboard works flawlessly. I have tried all the fixes mentioned in other threads but nothing helped. I tried ‘Particle server keys’ and ‘Particle doctor keys’ on CLI with no difference in the outcome.

Another scenario where device remains connected and responds to functions flawlessly is when I mount it on Asset Tracker Shield. So basically I can narrow the problem down to 2 scenarios

1- If device boots while on breadboard, it straight away goes to connecting loop mentioned above.
2- If device is already booted and breathing cyan and then mounted on breadboard it remains connected until a function call is made from CLI or external app. Once this happens the device goes into connecting loop.

Please someone from particle help me out as I am unable to prototype any circuits and app firmwares to continue my learning.


Ok I think Asset Tracker Shield is no exception. Electron connectivity is just relatively more stable on the shield as compared to the breadboard. I tested it by sending few function calls and after 5 or 6 successful calls the device eventually went into the connecting loop.

The only time it works reliably is when it is not mounted on anything.

I guess this is something for @BDub
Stay tuned

For cross reference I’ll also link back to your other post
Electron G350 connectivity (flash sequence)

1 Like

Anyone ?? no update. May be @corey can look at it !!

Its so annoying that I cannot do anything with the breadboard. Tracker shield is thankfully better than breadboard as electron manages to breath cyan after pushing new app firmwares most of the time. Occasionally it fails though.

One pattern that can be reproduced 100% is if I connect electron to cloud standalone and then mount it on a breadboard and issue a function call over CLI. It always ends up in the rapid cyan-red-cyan blinking cycle. That is so strange. Why it loses connection with Particle Cloud. And I am certain that the sketch on electron does not receive the call because it doesn’t make any visible state change. e.g. LEDs on/off.

Please help me out here Particle.


@noumanh, are you testing with a single breadboard or do you have others you can test with. Some breadboards are notorious for having parasitic capacitance between pins. Testing with another breadboard would be good. Sometimes even moving the Electron on the same breadboard can make the difference.

@peekay123 I tested it with two boards; one that came with the electron plus another I had lying around. Both exhibit same behavior. I got one from a friend today and going to test it on that one shortly. I will update here my results.


1 Like

@peekay123 Ok I tested with a 3rd breadboard and the result is exactly the same.

@RobMeades Did you find what was wrong with electron not connecting to internet when mounted on breadboard? You were to get 2 new devices when you last posted on this topic. Do they exhibit same behavior?


@noumanh, then it has to be something being off with the Electron, possibly the STM32 or the onboard regulator. There seems to be sensitivity on one of the exposed pins.

1 Like

@noumanh I live in an area where the preferred network (O2 in the UK) is quite weak and so, having a roaming SIM, the Particle Electron board tried to register on other networks, and did so, but was then unable to make a data connection through to the Particle cloud and hence couldn’t complete the application-level handshake. Plugging the Particle Electron board into another board simply made the reception worse (noise, etc.) and so made it more likely that the Particle Electron board would get into this state.

At least, that’s what I theorised. The problem was not present at my desk at work where we have very good O2 coverage.

I live in Pakistan and coverage for the Particle partner network here is good, telling from signal strength shown on my phone with SIM from same network. But I think I will give it a go by using a local SIM from a network with strong signal in the area. Let’s see if this solves my issue. Thanks for the advice :smile: at least I have something to go about solving this. Tired of staring at it blinking cyan for 3 days now :smile:

It might be worth asking for clarification from someone who knows what they are talking about (I know cellular in some detail but not how the Particle SIMs are configured).

Question is: the Particle SIMs are global roaming SIMs. They will have a preferred network operator in each country and some agreement with that network operator that data can be billed at some sensible rate. What happens when the network coverage from the preferred network operator is right on the edge but other network operators are available, network operators with which there is no such data connectivity agreement? If it were a handset, I might expect the device to register on an available network but not be able to do data. This is obviously not a desirable situation for the Particle Electron boards.

@KyleG, any chance to drag Brett’s attention to this topic?

Ya I will reach out to him!

1 Like

Hey all! Sorry for the delay. For those of you having this problem, some questions:

  1. Do you have a 2G or 3G electron?
  2. Do you have the beta electron antenna (flexible) or the production electron antenna (rigid PCB)?
  3. Does the problem still exist when you plug in just one row of electron headers and have the other row dangling out of the breadboard? So plug in the electron over one of the power rails in the breadboard (D0 side plugged in / A0 side dangles freely) vs (A0 side plugged in / D0 side dangles freely)

I’ve tried to reproduce this but have not had much luck in doing so… so it might also be a hardware issue on your unit. Please contact Support and ask to have your unit sent back for analysis to me (Brett). No guarantees on how many of these we can replace while we are investigating, but Support should be able to send you a replacement unit.