[SOLVED]Breathing Green

I’m really feeling like a noob now. I’ve tried for hours to reset my particle with no luck. There are problems while hooking up to my network etc etc. I’ve flashed it though cli with both old firmwares and new one’s. Trying to revoke key’s, and the list goes on.

Now I eventually got contact with the system again… and what happens? Short period (very short) of time the device is active (breathing cyan) and I can connect to the serial port. What do I see? My old App/program still run even that I flashed the device. Ok, so now I understand that the firmware is flashed to other areas and my program lies on another one.

There is not time for me to re-program my app before it goes offline, only time to hook up to my serial and read out.
I know the problem comes from that my app blocks the system for more than 10 seconds. How do I completely clear out my app area when not connected to the cloud (through cli)?


Have you tried safe mode?

You can also do

particle flash --usb tinker

sight This is what you get when you don’t touch your projects in a while.

Yes, the solution was to enter safe mode, alter the code and flash it.

Thanks for the help!