Setting up Photon with WEP WiFi security


I just got the new Photon and I can’t connect it to my network.
I tried all the setup and it didn’t work. It goes to try to connect to my network but it fails I guess.

I tried to reflash the device with dfu-util but I was unsuccessful.
I also tried to do a reflash with the particle utility (under windows xp)

  • “particle flash --factory tinker” ended successfuly
  • “particle flash --usb deep_update_2014_06.bin” failed.
    At the end it says: Downloading to address … then Download done then File downloaded successfully then Error during download get_status and then Error writing firmware …

Thank you

The deep_update is for the core only and does not work with the Photon.

Could you please flash the 0.4.3 release for Photon from here, and then try configuring WiFi again. Thanks :smile:


Thank you for your reply.
I was able to reflash the part1 successfully. Part2 though, it says: Download then Download done then File download successfully and then Error during download get_status.

I tried to re-configure the wifi network through the app but my Photon still does not attach to my WiFi network.


This is a known issue with dfu-util that we’ve not been able to resolve. I believe the firmware was updated successfully.

What security type does your WiFI network use - Open, WPA, WPA2, WEP etc…? And does it broadcast the SSID?


I am using WPA and my network broadcasts itss SSID. Also, i am at home on my network that is not complicated without any mac blocks or anything.


So just to clarify, when you use the mobile app, your network doesn’t appear in the list of SSIDs displayed by the app?

What channel is your network on (1-14), also is it on 2.4GHz or 5GHz?

Sorry for all the questions, just trying to get a picture of all the network details!


Sorry… I should have been more clear.
After the firmware upgrade, I put the Photon again in discovery mode, I start the app on the phone and then I start the configuration. The phone app finds my Photon (so it must be working in adhoc or access point mode), I go forward with the config, I select my WiFI network, I enter my WEP password then I get the 2 checkmarks saying … configuration saved or something like that. Then the phone app says it will switch the Photon to my network and then after a while it comes back with the “Oh Oh something went wrong” message and it gives me to option to go to the beginning.
After I power off/power on the Photon it comes on with a blinking green light.



A little bit more info.
I bought 3 of those … so I have one at work and I tried to set that one up. I reflashed it to the latest 0.4.3 and I used a wifi hotspot on my cellphone and this one connected to the cloud. I used a WPA2 as the encryption on this one so I may change the encryption at home on my wifi and let you know.


That’s the key - WEP networks are a little special. (You mentioned previously the WiFi was WPA. :smile:)

To setup WEP on the photon requires you add some extra information to the WEP password, specifically:

  • the index of the WEP key (0-3) (in your router it’s probably labelled 1-4, so just subtract 1)
  • the length of the key, typically 5 or 13 bytes
  • the key itself

For example, let’s say we have the key 123456789A at index 0, then this would be written as


Breaking that down:

  • 00 - this is the key index 0. Other possible values are 01, 02, 03.

  • 05 - this is the length of the 40-bit key (5 bytes - it’s the number of letters/numbers in the key divided by 2). Another possible value is 0D for 104-bit keys.

  • 123456789A - the remainder is the actual key


Got it!!
I’ll try that when I’ll get home … very excited about it.

Thank you for your help


I got it to work!
As you suggested, I entered the 00 05 before my key and it worked. One of the photons worked just like that, the other one I had to reflash the tinker since it was showing offline. Now I am a happy camper.

… I guess now I have to read a lot and get programming with it.
I really appreciate your help and your prompt answers.


1 Like

Thanks ! That worked for me too!

FYI, it worked for me when I made the length of the password 0D, even though the actual passkey I supply is only 13 bits.

The first digit is not the WiFi channel but the index number of the key. Routers have 4 keys, counted from 0-3 here, but some routers number them 1-4… Most likely the first number need to be 00, if the key is configured at index 1.

Sorry for the Lazarus here, but I ran into this for the first time on a project that I’m working.

I was unable to get several of my test units connected via SortAP. Tried to solve it over the phone… no dice.

Eventually on-site I realized that their router was WEP-PSK… it took me some time to track down this thread.

I’m concerned about this affecting the scalability of our product since this issue was found in at least 4 (so far) of the 25 devices we sent out for test.

Has there been a firmware solution to this issue, or is there a workaround that I can use. So far prefixing the password with “0005” has solved a couple of cases (still working on this). I’m not sure this would work for broad distribution.

Any thoughts out there? I’d like to know if this will cause me big headaches later.

This page has more tips for setting up WEP:

1 Like

Thanks, but imagine deploying a product across a broad spectrum of users and hardware configurations… I’d like to say I’m in the 90th percentile on network/wifi setup but gosh darn it, it took me time and a site visit to figure that one out and find the solution here on the forum.

Ironically, the guy I helped today was a sales** guy for an enterprise infrastructure provider!

** not intended to impugn the technical competency of sales people in general.
1 Like