Setting up Photon/P1 on WPA Enterprise (0.7.0)


#83

Log file returned. The reason it is still not connecting is this:

Error with TLS client handshake 5023
TLS handshake failed
Supplicant received link event
0000033757 [hal.wlan] wlan_hal.cpp:623, wlan_join(): ERROR: wiced_join_ap_specific(), result: 1007

1007 error is UN_KEYED , what is 5023?


#84

5023 is not assigned in the RFC for Radius servers.

The internet seems to think that 5023 means that the router has seen a device with this MAC address before and so it is trying to avoid spoofing. Could that be happening here?

Can you see what devices are provisioned on the router?


#85

@bko

I have checked the MAC address screening/ white list - there was nothing there. However, in the system log on the AP there was this:

Nov 12 14:37:24 kernel: e0:4f:43:xx:xx:xx had associated successfully
Nov 12 14:37:24 kernel: [WLAN] EAPOL process start.^M
Nov 12 14:37:31 kernel: e0:4f:43:xx:xx:xx had disassociated.
Nov 12 14:37:31 kernel: [del_web_portal_client] but hash_id:[37] is empty!

Can anyone help with what hash_id[37] is empty! means and whether it is significant. Other photons have the same message but with a different number in the hash_id:[xx].


#86

Dave, any update on this thread? I have been contacted again by customers wanting to know when WPA Enterprise security will be supported. There still appears to be an issue here with certain signature methods causing the TLS handshake to fail. I have tried the same code on a CISCO AP and I cannot connect there either.


#87

Armor,

I will re-ping the fellow that was supposed to review the log. My apologies for the delay.


#88

I just heard back from the engineer. He will look at it “tomorrow” (he’s 15 hours ahead of Pacific Standard Time).


#89

Thanks