Service issues at Particle => Claiming a device

is there some kind of Service interruption issues today?

when trying to claim a device, we are getting this error from Particle:

2017-03-26T18:52:36.176Z	5de490f4-1255-11e7-8258-c57c6dd08f7d	body:
    "ok": false,
    "errors": [
        "TypeError: Cannot read property 'equals' of undefined"
$ curl -d access_token=<access_token> -d id=<our id>

@BulldogLowell, did it work when you tried again?

I tested claiming and that went ok.

It worked for me but I am not using the products stuff if that makes a difference.

1 Like

Yeah, I’m in the Products space. We had it working fine but it fell apart just today. We are checking the latency to see of that is a factor. We are dealing with API calls from Germany, our servers on the west coast (US) and Particle’s east coast servers…

More on this tomorrow, I guess.


Could someone at Particle help me?

We have determined that we have a device in some funky state and we cannot claim it. We can however claim other devices.

I can PM the device number and perhaps you can tell us what we did that it ended up in this state. The error is coming from Particle, for sure.

@bryce are you able to look at this?