Not able to claim device from commandline

I have been trying to claim a device . I have few customers inside of product i am logged in from the customer username and password using particle-cli . When i try to add device by using

particle device add 37xxxxxxxxxxxxxxxxxxxx

It gives me error:
Failed to claim device, server said: user not found

It is same with the Particle Cloud API too. I tried using URI “” with parameters “id” and "access_token"
but same result.


@privatejava, have you a) got the latest Particle CLI (v1.27.1) and b) logged in to the CLI with particle login?

If yes to both, log out and then back in again to see if it works.

Is this for a Photon/P1? That’s not how you normally claim customer devices. Normally you create a customer, or create a customer access bearer token if the customer already exists. You then use this token to create a product claim code for the device. Then you use the claim code to claim the device, on the Photon/P1.

It’s the second half of this document if you want to walk through the process manually to get a better feel of how it works:

1 Like

I updated my particl cli to v.1.21.1 and logged in with customer credential and it still shows the same error.

It is particle electron and i have been claiming the same device past few months but all of sudden it is not working so i am worried and wanted to know if there has been any changes on the particle end.

The CLI responds with “user not found” after successfully confirmed login.
Please test whether other CLI commands can be executed successfully (eg particle list) or also lead to an error message. This can be used to narrow down whether your user account has a problem in general or your Electron as a single device.

Listing of devices command works well without any problem.

There was a problem using the device claim endpoint with a customer account. A fix was deployed and it should work properly now.


It worked perfectly !! Thanks you for quick deployment :slight_smile:

1 Like