Serial port times out after setup

Do you have DFU-util or CLI installed?

Yes. I just deleted everything to start from scratch. I followed your tutorial at:

to install the DFU driver, and I installed CLI following this:

I’m getting all the way through setup, but then it just sits there and flashes blue at me. Once again, I seem to get positive feedback that everything is set up ok, but then nothing happens. Here’s the log, maybe you can see something wrong. Sorry, I don’t know how to put this into a code block:

Your environment has been set up for using Node.js 0.10.33 (x64) and npm.

C:\Users\tanya>npm install -g particle-cli
npm WARN engine boom@2.9.0: wanted: {“node”:">=0.10.40"} (current: {“node”:“0.10
.33”,“npm”:“1.4.28”})
npm WARN engine hoek@2.16.3: wanted: {“node”:">=0.10.40"} (current: {“node”:“0.1
0.33”,“npm”:“1.4.28”})
npm WARN engine cryptiles@2.0.5: wanted: {“node”:">=0.10.40"} (current: {“node”:
“0.10.33”,“npm”:“1.4.28”})
/

serialport@1.7.4 install C:\Users\tanya\AppData\Roaming\npm\node_modules\parti
cle-cli\node_modules\serialport
node-pre-gyp install --fallback-to-build

[serialport] Success: “C:\Users\tanya\AppData\Roaming\npm\node_modules\particle-
cli\node_modules\serialport\build\serialport\v1.7.4\Release\node-v11-win32-x64\s
erialport.node” is installed via remote
C:\Users\tanya\AppData\Roaming\npm\particle -> C:\Users\tanya\AppData\Roaming\np
m\node_modules\particle-cli\bin\particle.js
particle-cli@1.8.3 C:\Users\tanya\AppData\Roaming\npm\node_modules\particle-cli
├── fast-luhn@1.0.2
├── cli-spinner@0.2.1
├── xtend@4.0.0
├── cli-table@0.3.1 (colors@1.0.3)
├── chalk@1.1.1 (escape-string-regexp@1.0.3, ansi-styles@2.1.0, supports-color@2
.0.0, has-ansi@2.0.0, strip-ansi@3.0.0)
├── when@3.7.3
├── node-wifiscanner2@1.1.0 (os-locale@1.4.0)
├── glob@4.5.3 (inherits@2.0.1, once@1.3.2, inflight@1.0.4, minimatch@2.0.10)
├── request@2.63.0 (aws-sign2@0.5.0, forever-agent@0.6.1, caseless@0.11.0, strin
gstream@0.0.4, tunnel-agent@0.4.1, oauth-sign@0.8.0, isstream@0.1.2, json-string
ify-safe@5.0.1, extend@3.0.0, node-uuid@1.4.3, combined-stream@1.0.5, qs@5.1.0,
form-data@1.0.0-rc3, mime-types@2.1.7, http-signature@0.11.0, bl@1.0.0, tough-co
okie@2.0.0, hawk@3.1.0, har-validator@1.8.0)
├── hogan.js@2.0.0
├── moment@2.10.6
├── lodash@3.10.1
├── softap-setup@1.1.4 (nconf@0.7.2, node-rsa@0.2.25)
├── inquirer@0.8.5 (ansi-regex@1.1.1, figures@1.4.0, cli-width@1.0.1, through@2.
3.8, readline2@0.1.1, rx@2.5.3)
└── serialport@1.7.4 (bindings@1.2.1, sf@0.1.7, async@0.9.0, nan@1.8.4, debug@2.
2.0, optimist@0.6.1)

C:\Users\tanya>npm update -g particle-cli

C:\Users\tanya>particle login
? Please enter your email address: @*
? Please enter your password: ******

Successfully completed login!

C:\Users\tanya>particle setup
_ _ _ _
_ __ __ _ _ | |() | | ___ () ___
| ’
\ / _` | '
| | |/ | |/ _ \ | |/ _
| |) | (| | | | |_| | (
| | /| | () |
| .
/ _,|| _|_|_
||__(
)|___/
|
| https://particle.io/

Setup is easy! Let’s get started…
It appears as though you are already logged in as *********
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We’ll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer
is connected.
! PROTIP: You will lose your connection to the internet periodically.

? Found “Photon-EJ8F”. Would you like to perform setup on this one now? Yes

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to
proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

Obtained magical secure claim code.

! I am unable to automatically connect to Wi-Fi networks (-___-)

? We can still proceed in ‘manual’ mode. Would you like to continue? Yes
? Please connect to the Photon-EJ8F network now. Press enter when ready.

Now to configure our precious Photon

! PROTIP: If you want to skip scanning, or your network is configured as a
! PROTIP: non-broadcast network, please enter manual mode to proceed…

? Would you like to manually enter your Wi-Fi network configuration? No
? Please select the network to which your Photon should connect: (Use arrow keys
? Please select the network to which your Photon should connect: *************

? Please enter your network password (or leave blank for none): *************

Here’s what we’re going to send to the Photon:

Wi-Fi Network: *******
Password: *********
Security: WPA2 AES

? Would you like to continue with the information shown above? Yes

Obtaining device information…
Requesting public key from the device…
Setting the magical cloud claim code…
Telling the Photon to apply your Wi-Fi configuration…
The Photon will now attempt to connect to your Wi-Fi network…

Configuration complete! You’ve just won the internet!
? Please re-connect your computer to your Wi-Fi network now. Press enter when re
? Please re-connect your computer to your Wi-Fi network now. Press enter when re
ady.
! It doesn’t look like your Photon has made it to the cloud yet.

? What would you like to do? Reconfigure the Wi-Fi settings of the Photon

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to
proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

Obtained magical secure claim code.

? Please connect to the Photon-EJ8F network now. Press enter when ready.

Then I disconnected it, plugged it back in, it flashed green, then cyan, then magenta, and I got all hopeful that it was going to work this time. Then it just went solid green. I gave it about 10 minutes. I cycled power, and same thing, just solid green.

Solid green is caused by it not being able to connect to wifi. That particular issue is fixed in the 0.4.6 release, due out this coming Wednesday.