SdFat Library Issues

I am adding the SdFat library to a project but am having issues where whenever I compile it says there is no such file in the directory? I have added the library properly through the Web IDE and see it in the library tab for the code. I have other projects that have the same library and compile correctly. I have tried both <SdFat.h> and “SdFat.h” with no luck. I am not sure what to do and any help or insight into this would be much appreciated! Thanks!

Is the selected device in the Web IDE (the one with the gold star) running system firmware 0.6.0 or later? The target system version after clicking the > to the right of the device name.

If it’s running an older version, the library won’t work and you’ll get that message.

The device is running 0.7.0

Added exact same code to a different file and it worked. Not sure why or how but thats what I did to solve it. Thanks

The distinguishing factor is not what version you’ve got on your devcie but what you’ve set your IDE to build for - this might not be the same.
To make matters more complicated, it also makes a difference what target version was selected when you created the project - if it was sometheng before 0.5.3 the project structure is fixed to legacy format and only a new project with a target greater or equal on creation will work with a library that’s meant for the new structure.