[Resolved]- "Sick" Electron

I have a particular Electron that is having trouble maintaining connectivity to the network and freezing among other things. I have multiple electrons and it is only this one that is giving me problems. Updating the firmware to 0.5.3 has not fixed it. Deactivating and reactivating the SIM has not solved it.

Is it possible to exchange this Electron for a new one? It has been like this since I took it out of the box.

I should also add that the firmware that is on the “sick” Electron is identical to the “good” Electron. I have also tried refreshing the firmware to 0.5.3 and the update either hangs or I get an “Aw, something bad happened” message.


In this case it’s best to open a support ticket at https://support.particle.io

1 Like

Support really helped me out. It turns out that the CLI is the solid way to update the firmware. Here are the instructions from Particle support:

Install the Particle CLI
Grab system part 1 and part 2 for your device from the release page.
Put your device in DFU mode.

Issue the command particle flash --usb <name of part 1 binary>
Issue the command particle flash --usb <name of part 2 binary>
Issue the command particle flash --usb tinker.

You device is now updated and has a recent copy of tinker on it.

It looks like 0.4.8 firmware for the Electon is buggy and allow the electron to fall into a non-communicating mode but still breathes cyan as if it was connected. Thus far, the units that have been properly flashed to 0.5.3 seem to stay in communication and a new Electron that I deliberately left at 0.4.8 went “no-comm”. I have re-flashed that “bad” unit and am going to see if it keeps operating.


Updating to 0.5.3 version of firmware over the CLI seems to have corrected my issue. Thanks again Particle for the great support!

1 Like