[Resolved] Electron online but not working

Hello. I’m stuck in a strange problem with my Electron. I had it working for a few weeks with the basic web controlled led app and now it doesn’t work anymore. I did not change anything. The thing is that it appears online at https://console.particle.io/devices and it is also breathing cyan. If i disconnect it, it shows offline under Particle console, so it does connect to the cloud. However I am unable to flash it OTA and the API returns a timeout on any led toggle call. I’ve tried reflashing the app over USB, reflashing firmware, unclaiming the device and claiming it again, changing the keys with the CLI and although all of these attemtpts were successful, I’m stuck in the same situation after all these steps.

Do you have any suggestions ?


1.) do you have the electron with you?
2.) do you have particle CLI installed?

I do, and the CLI is installed.


1.) Can you do a: particle flash DEVICE_NAME tinker
2.) followed by a particle list online to see what functions are listed
3.) Do a particle call function DEVICE_NAME digitalwrite "D7,HIGH" and see if the blue led lights up

We tried a cloud-side fix that seems to have resolved some communication issues that other Electron uses saw over the last day or so. Would you confirm whether or not you’re still seeing issues with your device?

Hello. It works now. I did not change anything since I reported the problem, so I assume it was indeed a cloud-side problem. Thank you very much.

1 Like

Glad to hear it’s working for you! Going to change the post status to [Resolved].