[Resolved] Core stuck in flashing green mode

Flashing green means it cannot connect to the wifi. Here is a great tutorial to fix that problem. If you still can’t get it to work after that, just let us know and we can troubleshoot further.

Kevin @ Spark

That doesn’t work for me and I am not able to enter DFU mode. The MODE button doesn’t seem to work. spark setup doesn’t find any serial connections.

Got a multimeter by chance? I guess it might be possible the MODE button no longer works. I assume you have tried to do a factory reset?

Factory Reset Steps:

Hold down the MODE button, tap once on the RESET button and wait for ten seconds to do a Factory Reset, where the Core is reprogrammed with the software that was installed on the Core in the factory (the Tinker application). The LED should turn white for three seconds and begin flashing quickly; when the LED switches to another color the Core has been reset. This is useful if you encounter bugs with your firmware, or if you just want to get back to Tinker.

Hi @harrisonhjones Yes, I have tried factory rest, it doesn’t work. I do have a multimeter. How do I test if the MODE button is working?

Factory reset never fails. Are you hitting anf releasing the right buttons? There are labels on the core in case you are new to this.

Also, a video of you performing factory reset might be useful to see what’s going on :slight_smile:

While I do agree, to a point with @kennethlimcp that Factory Reset doesn’t normally fail if you’ve tried it and the mode button doesn’t seem to do anything then you can try this will your multimeter: refering to the below picture take a continuity reading between the two points marked “1” and then another reading between the two points marked “2”. Do this again when you have the button pressed (might be a little difficult). Let us know the result (should have 4 readings). Do this with the core unpowered just in case.

When I brought the core home, it was instantly able to connect to my home wifi because it already has those credentials stored.
@kennethlimcp I am sure I am hitting the right buttons and I am able to see the “MODE” and “RST” markings on the core. I just tried the factory reset again but it did not work. I am not even able to enter “Listening Mode” when pressing “MODE” down for 3 seconds or more- and the “RST” alone seems to work fine - hitting RST turns off the RGB LED for a brief moment and turns back on.

@harrisonhjones Thank you for the detailed illustration. Here are my readings:
With “MODE” button NOT pressed,
Between 1’s: No connection
Between 2’s: Connected
With “MODE” button pressed,
Between 1’s: Connected
Between 2’s: Connected

I have another core which was setup in a similar way. It was first connected to my home wifi and then I brought it to work and it was easily able to enter “listening mode” and I was able to connect it to the workplace wifi. Also, I put it to the same continuity test and it gives me the same readings as above.

Thanks for the response. The results you have posted indicate that the button works, at least electrically.

Unfortunatley I also have a hard time accepting that the factory reset isn’t working (I don’t doubt that you have tried, I just feel there’s some kind of disconnect going on here). Let me see if I can get someone else to chime in.

Edit: I hate to make you do this but I want to verify that you are reseting it correctly: can you confirm you are following the these steps:

  • Hold down the MODE button
  • tap once on the RESET button (keep pressing the MODE button)
  • Wait until the RGB light turns WHITE. It will turn yellow before turning white. Keep holding the MODE button down

Hi Harrison, yes I am following those exact steps. As a matter of fact, when I do those steps on the other core, it works perfect.

What does the core do when you hold down the MODE button and then tap the RST button? Does it ever transition to the yellow color? I wonder if the reset button is the problem. Does it do anything when you press it (with mode unpressed)? If not can you perform the same continuity test on the rest button for me?

Would you mind also trying another USB cable. It’s possible that the current one is cause low-voltage problems.

Oh, and finally, if everything else fails I’d like a video of how you are currently reset-ing it. I realize that seems silly but it’s sort of a required troubleshooting step before replacement.

Also, for anyone interested: https://www.youtube.com/watch?v=nGBSYyTo5xA (how to do a factory reset)

Nope, it never transitions to yellow. RST is fine I think because when I press that with MODE unpressed, the RGB LED shuts off for a moment and turns back on. I have tried another USB cable, doesn’t work.
So, I guess I will upload a video as you requested.

Factory reset attempt - youtube video

I noticed that your core is flashing white rapidly and that might indicate a damaged cc3000.

What happens when you hold on to the RST button? Does the led light go off completely?

Hi Kenneth, the core is not flashing white rapidly. If you see the video again, after pressing and releasing the RST button, the core turns off for a brief moment, then turns solid white and then starts blinking green rapidly.

And, yes, if I hold on to the RST button, the LED goes off completely.

Try holding on to the MODE button for like 10 seconds. What happens?

Maybe you have a damaged MODE Button in this case

Nothing happens… core is still blinking green.

Hey, it looks like your original problem has been resolved (pending a RMA I believe) so I’ve updated the topic to reflection the resolution.

However, If you feel that your problem still hasn’t been fixed feel free to continue positing in this thread!

I know this has been marked as solved already however no solution was really posted, and hence I just ran into this issue today here’s how I solved it.

first how I screwed it up, I accidentally touched ground with the RST pin, at this moment the core rebooted and went into flashing green mode, I had it connected to my PC so after not getting any response from the factory reset I decided to try the serial port.
To my surprise I had a new unidentified device in the device manager, and part of the name was DFU, at this point I figured the core is probably stuck in DFU mode so I flashed it with the latest firmware and voila, back to business.

Hopefully this will help anyone else that may encounter the same issue.

Here’s a link to help you install the DFU drivers and util by kennethlimpc

And here’s a link to the tutorial on how to flash the core (including the download link)

1 Like

Thanks for the post @LPG. Just to confirm, the core was in DFU mode while flashing green? That’s not supposed to happen but I could see it happening. Thanks for the heads up/info

@harrisonhjones, it was flashing green and i think yellow as well, however the yellow wasn’t very strong so it looked green, it wasn’t full solid green though if that’s what you were referring.