Core does not work most times

Most of the time when i power on the core it flashes white and I’m unable to upload firmware to it. Tried putting it into listening mode but it does not flash blue. Also, tried factory resetting it but it stays flashing green. Had to try many times resetting and putting it into listening mode. If I’m lucky, it miraculously just connects, if not, it just does not work.

So it’s new and you only reached the flashing green stage am I right?

Sounds like a corrupted factory reset firmware. …

You can choose to get the core exchanged or attempt to re-upload the factory reset firmware if you want to try!

i tried factory resetting, initial flash is yellow/greenish, then white then yellow/greenish again before i release the MODE button, then it just stays yellow/greenish. Am I doing the factory reset correctly ?

Hold down BOTH buttons and release only the RST button only.

Wait till the Core flashes white rapidly and release the MODE button.

It should start blinking blue after :slight_smile:

looks like it might have been a faulty product, cause it flashes white and not blue.

It’s not faulty, just a corrupted factory reset firmware or bootloader :wink:

You can change the factory reset firmware:

Or email to perform and exchange.

@steph, need your help :slight_smile:

hi kenneth,

i tried upgrading firmware as per your tutorial but it still doesn’t work. Is there another way to check firmware version cause i can’t enter listening mode.

We can roughly tell by the time you bought the core but the long term plan is to have sort of a firmware tag which can be read via USB etc!

So you can’t get into DFU mode aka blinking yellow?

The simplest way would really be to swap 1 for 1.

@steph alert alert :smile:

@kcinimod Yes please let us know if you’re still having problems! Happy to do some more troubleshooting with you (cc: @Dave) or swap yours out if you’re ready.

(thanks for the heads-up @kennethlimcp!)


I managed to enter DFU and did the firmware upgrade as well. Then, I did a factory reset. But the problem remains, when I power it on, the LED just stays flashing white. I borrowed my friend’s core just to compare and his turns flashing green almost immediately.

It’s really weird and I suspect that the bootloader is cranky!

Seems like exchange would save you more hassle and time to get it working.

Send an email to yeah? :slight_smile:

Hi @kcinimod,

Sometimes flashing only white at startup can indicate the Core is having a hard time talking to the CC3000, and could indicate a manufacturing issue. If you email us at we can exchange your core for a working one.


1 Like

Thanks Kenneth and David. I’ve emailed already but it’s taking some time.

1 Like

Just popping in to say I’m replying over email. :smile:


1 Like