Renaming a Repo for a Published Library?

Is it possible to rename a repo for a published library?

I’ve renamed my to Is there any way to now update the library in the web IDE? When I try to use the new repo name it says that the name is already taken. When I try to use the old name it the validation page is just blank.

Do I just need to rename it to the old repo name to get it to update? Or is there a way to delete the old library so I can publish from the new repo?

Also, side note. It doesn’t seem to like it when I renamed spark.json to particle.json like the docs said I should.

@Azdle, have you changed the version number in your json file? It won’t update unless you bump the version number.

Yep, the web IDE is showing 0.0.1 and my json file has 0.0.2.

So, I guess that means no?

@Azdle, I am having the same problem and raised the problem to the Particle team.

Awesome, thanks @peekay123.

Hi Patrick,

to do this you have to delete the library first, then import and publish new version.

1 Like

@suda It won’t let me delete it because others are using it, “Library has 25 apps that still include it, please bring this to zero to proceed.”

Okay, so I’m dumb. Apparently I have two different accounts and had originally published that library under the account that I had forgotten about. I went and tried to publish it again, with the new name for the repo, on the other account and it worked just fine.

1 Like