Removed library still included

Hey team,

I have been working with some imported libraries. The problem is the library will not compile on the Raspberry Pi. (SPIclass not having beginTransaction). So I removed the library (it no longer shows in the WebIDE), and imported the code itself as files and fixed the problems. The problem is that the old libs are still trying to compile. I cleared the cache, signed out, signed it, and still, it tries to compile the old stuff.

I had problems earlier too today when adding libraries and the IDE would not completely add them. The include files could not be found at compile time. I had to create a new app and re-add everything and that solved my problem. I cannot keep on recreating new apps everytime I include a new library or remove one…

I am using the WebIDE, Chrome, OS X 10.13.6, I can usually compile for Photon without too many problems. This project requires a hardwired Ethernet so must use a PI.


Have you tried Particle Dev?

The potential cause for this is that the original library was already "pre-compiled" once and since you removed the library no code changes will ever be detected there to render these pre-compiled binaries to become invalid and the linker obviously picks the old binaries over the new ones (located in some other sub-path of the project).

Two work-arnounds:

  • change the name of the header file and include that instead
  • create a new project which never imported the online library (e.g. via tha SHARE THIS REVISION feature)

Do you need the cloud connection to go via Ethernet or just TCP/UDP traffic?
If the latter you could use an Ethernet add-on - like in this project


Thanks for the tip about changing the library include file name. That will come in handy,

I need the cloud connection. The device is inside a cement bunker type installation so no signal gets in. In the end, I used a Data over Power Line approach that provides its own Access Point. So I have an AP with a single device on it, Photon, with cloud access. A lot to deploy but it works in the end.

Thanks again.

1 Like

The Particle Dev will not allow you to code for the Raspberry Pi as its OS is too old. At least this is what I am seeing. If anyone knows how to fool the Particle Dev, please let me know.