Recovering or replacing Argon on a mesh network

I have a mesh network with one Argon and 4 Xenons. Argon is used in MANUAL mode- OS1.5.2. While trying some code changes, the Argon seems to have gone down (blinking green continuously after flashing). Now whatever I do it’s the same behavior, successfully goes to safe mode, flash code (tried multiple pieces of code, previously working). Immediately goes to flashing green continuously. I tried multiple OS versions, both newer and older than 1.5.2 with no luck.

  1. Is this a known issue, may be corrupted OS? How do I recover the Argon?
  2. If I want to replace this non-working device with a new Argon device. Is there a way to add this new device to this existing mesh network? When I try to bring up the second Argon, it will only allow me to specify a new mesh network, not the previous existing one. There must be a way around this?
    Any help appreciated

Are you certain a different Device OS version didn’t get selected as the target when you built? If an upgrade was accidentally attempted, that’s the behavior you’d see because the Argon would go into safe mode to get the missing system part and bootloader upgrades, which would cause blinking green even in manual mode.

You can tell for sure by going into listening mode (blinking dark blue) then doing a particle serial inspect from the Particle CLI. That would show a missing dependency.

Make sure you do not clear credentials, unclaim the Argon, or try to replace the Argon. If you do so, you’ll need to set up the mesh network from scratch again. There is no way to replace a gateway on an existing mesh network.

1 Like

@rickkas7 put the argon in listening mode. particle serial inspect times out (using the powershell). Any steps I missed? If I open a serial CLI, I don’t get a prompt.

Given the mesh deprecation, will I be allowed to to create a new mesh with a new Argon and existing 4 Xenons? Trying to look at some backup options.

You can currently still build new meshes if you do get a new Argon. I had to make a new one then move my xenons over after I picked up the wrong power supply and stuck 12v into my argon. You can’t just slot one into an existing mesh. However it will not be like that for long and at some point if your argon is wiped or broken then I believe that is the end of your mesh.

Looking at BLE to send messages to and from an argon, then let the argon call all the useful particle functions is getting close to the top of my todo list.

It does not sound like you need to buy new hardware. Have you tried running the phone/tablet app? If you run that , select your argon and then go into network, you can see what wireless and what mesh network it is trying to attach to. It may have just lost it’s wifi settings. It should also confirm your OS version.

1 Like

Here’s an update. It’s actually waiting on Mesh.ready(). Here’s the test code

int publish_count;

void setup() {

  // Put initialization like pinMode and begin functions here.

  pinMode(D7,OUTPUT);

  Mesh.on();

  Mesh.connect();

  waitUntil(Mesh.ready);  //it gets stuck here and flashes green. Used to work OK before

  publish_count=0;

}

void loop() {

  Mesh.on();

  Mesh.connect();

  waitUntil(Mesh.ready);

  if (publish_count>=120){

    publish_count=0;

   //switch on WiFi and publish, then switch off.

   // WiFi publishes are going through fine.

  }

  delay(1000);

  Particle.process();

  digitalWrite(D7, !digitalRead(D7));

  publish_count++;

  // The core of your code will likely live here.

 }

What are possible reasons for Mesh.ready() false?

Does it still know it’s mesh details?

I’ve had xenons which just forget.

1 Like

I replaced the Argon, defined a new mesh network. It was then simple to transfer all the Xenons (using the Particle iPhone app) over to the new mesh. Thanks @DaveH for your suggestions.

I tried to check Mesh credentials on the old Argon, it fails to even pair with Particle App (flashing blue LED). Makes me think, there is some basic (probably RF hardware) issue with Bluetooth/Mesh.

1 Like