Recovering from non-responsiveness

My Electron suddenly stopped responding last night as I was flashing firmware to it. The system LED went off completely and has not lit back up since. The D7 blue LED appears to be on dim and the red battery light remains functional.

I was flashing over the air and it stopped responding, so then I tried the USB cable (which had worked before) and the computer did not recognize it at all anymore.

The code was working and it was very simple read and writes. It was powered on regulated 12V VIN, and plugged into non-high-powered USB. I don’t believe it should be a power issue since the max rating is 17V anyway. The D7 light is still on, and I noticed D2 and D3 have voltages (~3V). It seems like the device is stuck in some mode or reset.

I’ve been trying to read about jtag programming, but it’s hard to absorb. I just ordered an STLINK programmer anyway. Can you guide me in the right direction? Could this help me restore/reset the Electron, even if my computer is not recognizing it via USB?

Thanks for any info you can shed.