Pulsing cyan but can't flash from /build

Hi, I’ve been stuck on this for about a day.

During a day of heavy coding and many re-flashes my core has stopped responding to flashes from build.

I have factory resetted it numerous times and tried connecting through a different WiFi network (setting up credentials through serial terminal each time) and it hasn’t helped. I’ve also tried flashing different programs from the cloud such as “BLINK AN LED” in case there was something wrong with my program, but it never even goes magenta.

When I connect power the boot sequence is: solid white, flashing green, flashing cyan then pulsating cyan as if everything is ok.

Clue: Every so often it stops pulsating, starts flashing cyan slowly, then flashing cyan quickly, then continues pulsing cyan again. It’s as if there’s some kind of watchdog taking over and reconnecting to the cloud?

Also: It seems similar to this post, except I can’t see my core online from the IDE like the screenshot he provided (no light blue circle).

Pulsing cyan means attempting to handshake with the :cloud:.

it needs to be be breathing cyan… can you perform a factory reset and check to see if this works with factory tinker firmware?

Hi, sorry I think I’ve mixed up my terms a little. I thought pulsing was the same as breathing, as opposed to flashing which means… well… flashing. As far as I know, the core is already “breathing” cyan i.e. the light is slowly fading in and out. Please correct me if I’ve got my nomenclature wrong.

I’ve never played with the firmware, but I have performed numerous factory resets by holding mode, clicking reset and waiting until it flashes yellow, then solid white then flashing white before releasing the mode button. After this it goes blue and I enter new WiFi credentials over serial. Then I’m back to square 1. I.e. breathing Cyan, but unable to be flashed from /build.

Are you suggesting that I have to do some kind of JTAG or CLI firmware reset instead?

I’ve also confirmed that my core ID is correct by matching the value in the cloud with the value that I can read over serial.

EDIT: I decided to remove my core from /build and reclaim it just to see what would happen and now it won’t let me claim my core at all. I’ll investigate more and post back if I find anything useful.

I’m suggesting that you perform a factory reset, make sure the core and breath cyan and check its status on the build/cli :wink:

Thanks for your help on this kenneth.

I installed npm and ran spark setup. Connected to wifi ok. Got it breathing cyan. Then, it says it can’t claim my core.

Thanks! Wait about 7 seconds while I save those credentials...

Serial said: Awesome. Now we'll connect!

If you see a pulsing cyan light, your Spark Core
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit https://www.spark.io/support to debug.

    Spark <3 you!

Done!  Your core should now restart.

Please wait until your core is breathing cyan and then press ENTER

Claiming your core

Failed to claim core, server said  [ 'Device is not connected' ]
Please wait until your core is breathing cyan and then press ENTER

Trying to claim manually also fails.

MacBook-Pro:~ megabyte$ spark cloud claim 53ff7.....
Claiming core 53ff7.....
Failed to claim core, server said  [ [ 'Core isn\'t online', 404 ] ]
Potentially unhandled rejection [1] {"ok":false,"errors":[["Core isn't online",404]]} (WARNING: non-Error used)

(I truncated the core id since it’s probably not wise to post here)
I’m starting to wonder if something is wrong at the cloud end? I did notice earlier that the settings page in /build said my access token had expired, but renewing it from the browser didn’t help anything either.

UPDATE: Today everything is working fine. I’m able to claim the core and flash from /build and all is well. I guess when you get stuck you just gotta chill for a few days and everything will sort itself out in the cloud eventually.

1 Like

I’m having what seems to be the same problem.

The board is breathing Cyan. And the IDE has the small blue dot indicating a connection. But I’ve tried multiple flashes of a good program and they all fail.

Then dashboard at: http://jordymoors.nl/interface/ does say that the unit isn’t online. It usually seems to track real well.

I did a factory reset on a Core that this was happening to and then “Removed a Core” on that part, and now I can’t get it back, so I’m loath to try that again. I’ve only got so many Cores.

I have been able to program and run programs on all of these cores, but now I can’t seen to get a good flash.

Is the Spark Core meant to be used in production systems? The Web development system, at least, seems to rather unstable. Sometimes things work, some times the same things don’t.

1 Like

Hey @MarkSHarrisTX, if you can, can you try connecting over a different wifi network and ISP if you have one available? E.g. use your phone as a WiFi hotspot and connect over its cellular connection. I’m just interested to know if it’s some kind of DNS thing.

Okay. I’m not sure Sprint lets me set up a Wi-Fi hotspot. At lease not without me paying them more money.

Maybe I should go buy another Wi-Fi Switch. My current one is a D-link one. and several years old. Maybe I should have another to use, although I hate going through setting it up again. Maybe I can use both together or simply turn off the D-link for wi-fi and use the new one.

Okay, I went and replaced my Wi-Fi/router with a newer model.
Old model was a D-Link about five years old.
The new model, and much more expensive, is a NETGEAR R6300Smart WiFi Router, AC Dual Band Gigabit.
However, I’m still getting unsuccessful downloads,
On the Spark Cores page I do have next to the Spark a yellow star. I also have a turquoise blue dot near the “>” that means I’m online.
But overtime I try to download something, it says taking longer than usual, and then finally says"Flash unsuccessful".
I have tried to factory reset several cores. This one is almost brand new.

Is it running in abg mode?

I’m having this exact same issue. Core is breathing Cyan, I’m able to read events from the cloud, and /build is showing the status as online.

However, trying to Flash (either my own program, or Blinking LED demo) results in a “Request Timeout, Flash Unsuccessful”, no magenta flash.

I’ve been able to do other things from Build, like Rename the core (verified by doing a /devices API call.

Should I be trying to flash from the CLI, I’m a little confused because the docs for CLI seem to conflate doing a flash with doing a deep update? (I’m running 1.29 on my core apparently)


This will really be dependent on what code you are running (probably some with delays).

You can open up a new thread and we can take a look :wink:

I have the new router running in:
2.4Ghz b.g.n
5Ghz a.n/ac

I don’t remember how the old router was set up, but I suspect it was 2.4Ghz b,g I think it was too old to have n., but maybe it did.

I did take a brand-new Core, set it up, download the LED test program and then download one of my programs and it seemed to flash okay.

However, prior to that one, I was having trouble flashing as detailed above. I will now go back and try to program some of the Cores that didn’t want to before.

Let’s be on the same page first :slight_smile:

Flashing cyan means attempting to connect to the cloud so you will not be able to interact with the core in any way.

I guess you have spark-cli installed?

The n setting might be the issue so try to use b/g mode if possible

Okay, I figured out how to turn off the 5 Ghz portion of my router. I don’t see any way to turn off the n mode in 2.4 Ghz.

My core is breathing Cyan, not flashing cyan.

I can’t seen to get spark-cli installed. It gets an error when I try to install it on my Mac.

If I managed to get spark-cli installed, what does that allow me to do?

It really depends on what state you are in and we can try to fix it using Spark-cli

Are you able to interact with the core now?

Okay, I took my Cores to TechShop so I could try another router and have the same problem there.

Once it gets into this mode the only way out seems to be to do a factory reset. After I do that I can usually download new or the same set of code. Sometimes it seems to let me do this a few times, but then it gets into this state and I have to start over.

I do have one Spark that seems to start do a breathing cyan, but then starts doing a rainbow flash. Red, then blue then green, but I think that is another problem.

Every time I’ve tried to install Spark-cli I get an error.


1.) When you say get into this mode…what mode is that?

2.) Seems like your cores can communicate with the :cloud: fine with you saying that you are able to download code

3.) Are you on Windows or Mac? Spark-cli is now on V1.0.0 and should install fine

4.) Rainbow flashes means you probably used the Spark mobile app to send wifi credentials to the core? Then that should be normal

  1. By “this mode”, I probably should have said “this state”, I mean the point where the Core is happily breathing cyan, which I assumes means it is communicating with the Cloud, but has stopped responding to flash requests. Now that I have a working pushbutton, maybe I can see if it still responds to outside events.

  2. I can download code, once or twice, and then no more until I do a factory reset. I’m not sure if the Cores are communicating with the cloud. I’m working up to doing some subscribe and publish statements. Does breathing cyan guarentee communicating with the Cloud?

  3. I haven’t tried installing Spark-cli in over a week. I’ll try again.

  4. Yes, I did a factory reset, then use the mobile app on my iPhone to set up the wi-fi credentials and gave kept the same name. It then briefly goes to breathing cyan and then starts the rainbow flash of colors. What is normal? It should stay in the breathing cyan mode, I think. Why would it leave that mode and go to the changing rainbow colors if I haven’t done anything?