Problems with Spark Dev for Mac

Hi I’ve started seeing serious issues with the Spark Dev atom IDE on OS X since a few days ago. like malfunctions and screen corruptions. its been working fine for a while, this iust started a few days ago.

  1. there is a orange triangle alert in the footer bar with a 17, when you click it shows a number of issues of deprecated calls.

2a. there seems to be a black box obscuring the messages in the footer
2b. after there has been an alert from the top bar, there is a black box obscuring the tabs preventing them from being clicked

  1. when a compile fails, the info boxes you used to be able to click and it would take you to the offending line of code, now it tries to open up some ipo file in a new tab (which is obscured due to 2b above)

if you click Flash more than once, it pops an error window in top right in red, screenshot attached.

indicates the underlying atom may need updating?

i tried deleting the app and reinstalling it with no change, but i don’t know if there is a prefs file that needs to be zapped to do a proper fresh install with clean prefs.

Anyone else having trouble?

1 Like

It might be a new version breaking things. @suda?

Hi Jon,

deprecated calls warning is due to 3rd party packages, not yet updated to latest Atom API. They should work fine, but we’ll try to help their developers with update.

Could you paste a screenshot of the black box covering messages (2a) in the footer and the alert from the top bar (2b)?

As for showing errors and flash bugs, we’ll fix them ASAP.

I have v0.0.21, I haven’t upgraded it or installed any 3rd party packages, unless it does it by itself. problems just started happening a few days ago.

heres a screenshot right after compiling and clicking on the first error shown, instead of taking me to the line of the error, it blanked out the errors leaving a black box behind and tried to open a httpclient.ino file which doesn’t exist hence the blank window. you can also just see the footer bar has a black area blanking out any content after the “no devices selected” message

We’ve just released v0.0.22 which should fix errors you mentioned. Could you give it a try?

ok I have the new version and the black boxes have gone, and now compile errors show the correct line of the error and clicking takes you to it correctly.

its possibly too early to tell, but it seems that atom helper no longer hogs the cpu, which will be very welcome.

Theres still a couple of glitches with flash failures and the 17 deprecated calls alert.

i guess it was wishful thinking, atom helper is still hogging my cpu…2 instances