Problems from the outset


I initially got to the stage where it breathed cyan a few times and then it immediately starting flashing red in no distinguishable pattern. I’d hoped it’d be easy to get up and running by just plugging it in so I can just start coding but it would appear not. After trying factory reseting multiple times I’m now getting a breathing red and blue light which doesn’t appear to be documented anywhere. Any ideas?

Is there an easy way for me to get this thing running?


What is “this thing”? Not sure we can help much without knowing what exactly your talking about :wink:

I had some issues like this and what I had to do is use the spark software on my mobile phone and put in my network password again. This put the core back in the cloud and back to breathing cyan again. Have you tried that? I am new myself so this is not a guarantee but if you have not tried this you may want to. You my need to reset the WI-FI network information in the device to get started. See the getting started area for your device for step by step, but I am sure you know that. :smile:
Good luck!

After trying factory reseting multiple times I'm now getting a breathing red and blue light which doesn't appear to be documented anywhere. Any ideas?

Please see previous post. Thanks.

Factory reset and setting up new WI-FI settings are not the same. After resetting factory defaults I had to then tell it to go through setting up the WI-FI settings again. What type of device is it?


Thanks for your reply. It’s a Photon. Yeah, I’ve reset wifi and done a factory reset. I then go through the setup on my phone, it says it’s successfully set it up on my phone but the photon just breathes red and blue and never comes online…

If it’s your first time setting it up, it’s probably doing the initial upgrade, which is breathing magenta (red+blue). That can take a couple of minutes, depending on internet connection, wifi, relative position of the galaxy, etc. Give it some time, and it could/should work itself out.
Rather than doing a factory reset, upgrading to the latest firmware might be more beneficial. You’d currently have to install the CLI for that, but that’s worthwhile installing regardless.

Ah I wasn’t aware that breathing magenta meant that it was still connected. I clicked reflash tinker on my phone and went to breathing cyan straight away… Thanks all, I can get messing now! :smile: