Photon stuck flashing Green

Hey all.

I’m trying to set up a photon on a new wireless network, and it doesn’t seem to want to.

I originally attempted to connect two nights ago, and it worked. It connected to the network and to the cloud and functioned for about 20 minutes. Somehow it then lost connection and hasn’t been able to get back since.

I’m attempting to connect to a WPA2 Personal network. The routers online configuration says that only three of its known devices are connected to it; a phone, a computer, and the wireless printer.

Linksys EA6100 wireless router. My phone and laptop also won’t connect under “authentication problems”, which may or may not be relevant information.

I think it’s trying to receive an IP and failing, maybe? I don’t know. If anyone has any ideas I would love to hear them. Want to hopefully have the photon up and running before I leave it behind 2100 miles away from where I live.

Can you try clearing the wifi credentials and attempt to set the photon up again?

Yeah, I’ve cleared it about five times since and it hasn’t changed. Will attempt once more here in a minute.

Can you also try deactivating the 5GHz band or give the 5GHz a different SSID?
Does Safe Mode also not get beyond blinking green?

5GHz is a different ssid, didn’t show up during the set up process. And I haven’t tried safe mode yet because it’s in a pretty inaccessible spot (inside of a stuffed animal). I have a bunch of free time in the day tomorrow that I will get it out and try safe mode if that’s the next step. (Nice seeing you again ScruffR :))

1 Like

@ScruffR, I tried running in safe mode but to no avail. Still flashing green! I wish I had another WiFi network to test this on… Not really sure where to go from here.

Have you got a smart phone you could use as AP?
This is always good to have handy for testing (especially when you go round to friends to show off ;-))

I don’t have a plan that includes Hotspots, unfortunately. Relying on its ability to connect to the WiFi didn’t seem like an issue. I just don’t understand it… I brought my laptop, phone, and the photon… Neither my phone nor my photon can connect to the WiFi, and the Photon DID for a short while… My girlfriends iPhone connects fine, the Mac in the house also connects, as well as the iPad. It’s all confusing and it’s probably not an issue with the Photon at all. Thought I would try here anyways.

There are several possible reasons for devices not to connect.
Have you got MAC filtering active on the router?
Have you got “funny” characters in your SSID and/or password?
Have you got enough free DHCP IPs to hand out?
Have you power-cycled your router?
Are you mixing static and dynamic IPs?
The fact that all working devices are Apple branded might also provide a clue - just no idea which :wink: or are they actually connecting to the 5GHz network?

Temporarily try an open 2.4GHz network with a short/easy SSID. Then add a short/easy WPA2 password. And go gradually forward, till you’ve got to the settings you originally wanted.

First thought was IP limit hit by DHCP, but nope. Router has 50 it can hand out. No MAC filtering or parental controls active. Funny characters are also avoided with the SSID and password being only alphanumeric, no symbols. It is rather odd that they’re all Apple products, but it would absolutely blow my mind if that was the cause at work here. (Side note: I can see all the devices the router knows and whether they’re online or offline. Every single device, save the printer/copier, are Apple products. The Photon doesn’t show up there even though it has connected before.)

Dynamic / Static IP’s also crossed my mind. I thought I might try assigning my photon a static IP, but there isn’t a way to do that during set up on the Particle app for Android. (Would be a really nice (and complicated) update in the future when you manually select a network name.)

So I’m really at a loss. I could try reworking the password, but I don’t think that’s the issue. It’s just a 15 character alphanumeric, and the photon connected using the same password before.

The only thing left to do, I believe is to try to this.

I can’t figure out how to get DFU Utility to work on my laptop (which has no Internet connection, as you know.) I downloaded DFU drivers and DFU Utility 0.8 and have it set as an environment variable in PATH, but I can’t run dfu-util - 1 in command prompt…

Edit: didn’t realize that dfu utility was dependant on particle CLI, and i don’t have the time or means to install Microsoft visual studios. Looks like this route is out as well…

Sorry my formatting is everywhere, mobile is difficult. But thank you for all your help and patience

Hi @Jarmom

If you have an Apple router (as you said) a common problem is that they try to force all traffic to the upper 5GHz band. The solution is name the two bands with separate SSIDs (there is a check box to allow this) so that the router cannot force your device off of 2.4GHz.

There is no dependency of dfu-util on the Particle CLI or on Visual Studio for the Particle CLI–not sure where you got that. The dfu-util program is completely stand-alone and can be used and installed by the Particle CLI but works on its own too.

In a shell type which dfu-util and you should get an answer like /usr/local/bin/dfu-util. If you get no answer, that means it is not installed right or not on the path. Try echo $PATH in shell to see what you are searching.

By the way, the correct command is dfu-util -l that is dash-lower-case-L with no spaces.

1 Like

@bko, he’s got a Linksys EA6100 and the 5GHz issue was already addressed

I’m not sure about the OPs OS, but if it’s Windows then there would be no which command, but the dfu-util - 1 vs. the correct dfu-util -l crossed my mind too :wink:

1 Like

I’ve got similar issues with a photon of mine. It was working just fine for the last few weeks, and now I cannot get it connected to my wifi network. Stuck flashing green.

I’ve tried the trick where you pair it up to an iphone hotsot, but this will not work for me either.

Not sure what else to do.

Have you tried safe mode already? Also, try clearing the credentials by holding the setup button for ten seconds until the led starts blinking blue rapidly.
If you’ve got he CLI installed, you can try doing a system firmware upgrade, in DFU mode, if you haven’t yet done so by doing particle update. After that, place it in DFU mode again and do particle flash --usb tinker.

Awesome. @bko, @Moors7, I didn’t know that Particle CLI was a thing, really. I just tried following what people had said worked in the Common Issues thread.

I know the photon is working fine, and that the issues lies with connecting to the specific router. Bear in mind that this is part of a gift for my long distance girlfriend. Sadly it couldn’t be given to her at the time, but she’s more than willing to attempt setting things up while I explain everything! I’m going to be shipping this spare Netgear access point I have sitting around my room over to her. Hopefully, the photon will connect to the access point and the router will see it and let it through that way! If not, I really don’t know where to go after that.

Thanks again for all the help guys, I really appreciate it.

1 Like