Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]


Possible. You can use particle keys server to flash the Particle public key.


It seems like it downloaded the key, but the message is confusing about what the outcome is. It says new key is in place, but looks like it is not valid.
Here is the log:

particle keys server
Found DFU device 2b04:d006
spawning dfu-util -d 2b04:d006 -a 1 -i 0 -s 2082 -D C:\Users\Mau\AppData\Local\p
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #1 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash   "
Downloading to address = 0x00000822, size = 512
Download        [=========================] 100%          512 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Okay!  New keys in place, your device will not restart.

Does the invalid DFU suffix signature have to do with the .der file?
Anyway, I then proceeded to reconfigure the wifi from listening mode. Only the apple version of the
SoftAP app works and it gives me the same error about not being able to configure the wifi credentials.
It seems like the Android app does not handle this error gracefully and it stops working.


This is just the DFU program, which is general purpose and not Particle specific, complaining that in the future it will not take *.bin named files but instead wants *.dfu named files. You can safely ignore this.


I have a problem, I do this:

*******-MacBook-Pro:~ *********$ particle keys new
Found DFU device ********
New Key Created!

But then what?
(I put stars in for sensitive info?)


You should not need to use particle keys new
You either can use

particle doctor


particle keys server
particle keys doctor <yourDeviceID>

that performs all the required steps you’d otherwise need to do step by step yourself.


Many thanks, it was simpler than I thought!


I am still stuck.
The doctor app flashes successfully, but fails to run.

Flashing the Device Doctor app
This app allows changing more settings on your device
Put the device in DFU mode
Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.
? Select Continue when ready Continue

Flash success!
The Doctor didn't complete sucesfully. Could not find serial device. Ensure the
Device Doctor app was flashed

The photon cannot connect to the wifi. The configuration fails to setup the wifi credentials.
This photon has been working for over a year, until the battery died. It seems this can either damage the photon, or screw up the memory so bad that standard tools are not enough to restore it.
I saw one other post about this same issue. Is there a hardware bug?


It needs to be in DFU mode and connected via USB to your computer


Yep, did that. I ran particle doctor with the photon in DFU mode. It flashes the doctor app via USB and says it was successful, but it can’t run it.


Fixed it. It was a combination of PC issues and particle CLI install… quality.
I guess the PC I have been using is a little slow at recognizing USB devices.
When the particle doctor command flashes the doctor app, it seems that it runs it right away. However, the photon was disappearing from the USB temporarily and it prevented the doctor app from continuing.
I used a different PC and the doctor app continued to run.
It did its cleanup up to resetting the wifi credentials and then it tried to reset the server and device keys.
It runs openssl, but this program was not in the Windows search PATH. When I installed the particle CLI, it placed the particleCLI files in the AppData/Local folder and the openSSL files in C:.
So the last step of resetting the keys was failing and my temporary rage prevented me from seeing that Windows was not finding openssl.
I added openssl to Windows search path and my photon is back to life.

I am thankful that the doctor command was created. It would be really helpful if the particleCLI install script could prevent this PATH issue.

Thanks to all who responded.


On a clean machine the Particle CLI Installer does it all for you (including the PATH setup) already.
It’s available here (right down at the bottom of the page)


That’s where I got it from and is also reachable from the documentation: Particle CLI Installer
This installer updates the PATH only with the particle executable location. It does not add openSSL to the PATH.


Did on my clean machines tho’


I haven’t had any luck with any of the suggested options.
I’m still getting the quick flashing cyan with the quick orange burst. I’ve tried everything from setting it up on my phone to setting it up on my computer. I tried upgrading the device firmware with particle upgrade and then manually using the github repository and documented upgrade path. It seems like I can do almost everything via my phone except for claiming the actual device. Then, because claiming the device fails, everything else seems to fail as well. This all came sort of out of the blue.
The only thing I can think of was that one of my software firmware pushes had some of the wifi options included (disconnecting from wifi and scanning for a specific one) Could it still have retained the wifi.disconnect() command somewhere deep in the firmware even though I’ve reset it multiple times. Flashed tinker, updated keys, used the particle doctor. Also, my router has the 5Ghz capability, but the SSID for that one is different, so I’m only connecting to the 2.4Ghz. Someone suggested that it might have to do with a firewall on the router… anyone have any experience with that?
I’m kind of at my wits end with it.


You won’t need WiFi connection to run these commands in DFU mode and when you execute these commands, don’t just say you did, but post the output.

Isn’t it particle update? What was the output of that and what did particle identify tell you after it?


You’re right, it is particle update.
I found the trick though, even though I swear I’ve run the particle doctor like 10 times (because running the doctor on just the keys was not doing the trick.
I went through the full particle doctor command and subsequent prompts and finally had luck!
It turns out that the piece that was bricking my device wasn’t really bricking it, and it was the fact that I was missing SYSTEM_MODE(SEMI_AUTOMATIC); (my photon is running connected just to a local LAN)
Otherwise your photon will just try to endlessly connect to the cloud, essentially stuck in Particle.connect();


That explains everything :wink:


ps, frustrating that the particle cloud keeps bricking keys for client devices. Which requires them to mail them to us to fix up for them. Just had to fix another.


Hmm… Does the device sleep most of the time or always online?


I’ve suddenly started getting this issue on a system that’s been working properly for several weeks and that does not connect in any way to the Particle cloud. (i.e. “SYSTEM_MODE(MANUAL);”).

It started when I made a very small formatting change to the serial debug output and re-flashed. It now fast-blinks green, then fast-blinks cyan with an occasional orange double blink.

I tried flashing an empty project back onto the device and I get the same - blinking cyan with orange flashes.

I’ve tried running the device doctor. The first two steps succeed, but then I get a failure message when it attempts to set the Internal antenna. Here’s the output:

Stevens-Mac-mini:projects ssokol$ particle device doctor
The Device Doctor will put your device back into a healthy state
It will:
  - Upgrade system firmware
  - Flash the default Tinker app
  - Reset the device and server keys
  - Clear the Wi-Fi settings

The Doctor will operate on your Photon connected over USB
You'll be asked to put your device in DFU mode several times to reset different settings.

Updating system firmware

Put the device in DFU mode
Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.
? Select Continue when ready Continue

> Your device is ready for a system update.
> This process should take about 30 seconds. Here it goes!

! System firmware update successfully completed!

> Your device should now restart automatically.

Flashing the Device Doctor app

This app allows changing more settings on your device

Put the device in DFU mode
Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.
? Select Continue when ready Continue

Flash success!

Select antenna

? Select the antenna to use to connect to Wi-Fi Internal
The Doctor didn't complete sucesfully. undefined
> Please visit our community forums for help with this error:
Stevens-Mac-mini:projects ssokol$

Any ideas?