Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

Still broken, after a struggle to get Particle-CLI working again…

C:>particle keys doctor 37
Found DFU device 2b04:d006
Found DFU device 2b04:d006
New Key Created!
Found DFU device 2b04:d006
Found DFU device 2b04:d006
Saved!
checking file 37_rsa_new.der
spawning dfu-util -d 2b04:d006 -a 1 -i 0 -s 34:leave -D 37
_rsa_new.der
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

Opening DFU capable USB device…
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #1
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash "
Downloading to address = 0x00000022, size = 608

Download [ ] 0% 0 bytes
Download [=========================] 100% 608 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Saved!
attempting to add a new public key for device 37
submitting public key succeeded!
Okay! New keys in place, your device should restart.

This is with the Photon that died most recently without warning, without programming, just boom, Flashing Cyan and Red, NOT orange. Why are these Photons committing server suicide with nothing being done to them what-so-ever…Some have NEVER been programmed! (Only initial Tinker…)

Edit: Still above, but what does this mean? I caught it after my post…

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Saved!

I think that’s just a warning that in future the dfu-util will be stricter. Should be fine for now - mine reported that too yesterday but worked ok.

I have a problem like this too. Have tried all suggestions. The photon won;t start in safe mode. I can get it into listening mode and set up wifi but then (using the phone app) it fails at the last stage. Over serial I can do the same - set up wifi. When it restarts it does the flashing green startup pattern and then into the cyan flash with red burst mode. Tried the keys doctor thing in DFU mode and it says “No DFU device found”.
Pretty sure it’s bricked for good :frowning: It was definitely a brown-out that killed the keys and now I am unable to restore.

You already got an answer in this thread on your double-post

Thanks - and apologies for the double post - for some reason I thought I was posting elsewhere.

I can get the photon into either listening mode or into dfu mode just fine. It’s just that in dfu mode (yellow flashing light) I am unable to do any dfu-type stuff, such as restoring keys, because it reports back that there is no DFU device found.

Sorry again for the double post!

Hi everyone again.

Thanks to everyone’s help I’ve solved my issue! Many thanks all. Here is my full story of woe:

  • accidentally reduced power to my functioning photon - a brown-out. Resulted in failure to respond
  • wouldn’t boot in safe mode. Every time I restarted it it did the flashing cyan with dash of red now and then
  • from that mode I was able to reset into either listening or dfu mode fine
  • in listening mode I couldn’t get it to reconnect to wifi using the phone app as it would fail at the last stage
  • tried connecting to Windows PC with serial cable. Wouldn’t get recognised as a USB device in any mode
  • tried connecting to macbook. Wouldn;t get recognised as a USB device
  • tried again using different USB cable. Both machines again failed to recognise it
  • tried again with a third cable. It got recognised as a USB device! Could connect to it in listening mode, and tried setting wifi with ‘particle serial wifi’
  • STILL wouldn’t connect to wifi
  • tried the particle keys doctor. Reported back that DFU device was not found
  • help from above ^ told me that dfu needs a differenet driver than the listening mode driver
  • got DFU driver using this link: Tutorial: Installing DFU-Driver on Windows [24 Feb 2015] which meant installing Zadig
  • tried keys doctor again. Now reporting that OpenSSL isn’t available
  • installed openSSL as per this link :Tutorial: Particle-cli on Windows [07 Jun 2015]
  • still couldn’t find openssl. Found a post that mentioned the installation doesn;t add it to the path.
  • tried going into the openssl\bin directory and running the particle doctor thing from there.
  • it worked! And I am happy once more.

Thanks again all - for both the help and the patience. One day I’ll know what I’m doing…

@FlaredElectronics, could you provide a video of this (from power up till at least 10sec after the red flash)?


(I’ve pulled the double post with replies into this thread to keep things less messy)

1 Like

Sadly no, but only because I think I figured some things out and hopefully conquered the issue.

I will look around and make sure I didn’t make any Videos of the issues, but I did keep a primitive Wod Doc with the console/cmd info I typed.

I had 4 photons that were not working.

  1. Flashing Cyan/Red (Was working 2 weeks ago and just suddenly died)
  2. Flashing Cyan/Red, but recently got it to Flash Cyan/Orange
  3. Stays White, dispite Safemode/DFU Flash/Tinker Flash/Update/Factory Default
  4. Blinks Blue but does not show an SSID. (This is after it started Cyan/Red)

So number 1 and Number 2 are fixed, but it was not easy or something that was linear in any way. Here is what I did to fix 1.

Got the Cloud Key and Followed the Key process from this thread.
Sent the new key to the Photon (Didn’t work)
Got the ID and used the Doctor Command (didn’t work)
Upgraded the Firmware (didn’t work)
Tried the Cloud Key again (didn’t work)
Tried Safe Mode (didn’t work)
Tried Factory Default (didn’t work)
Tried Flashing Tinker (didn’t work)

So here is the formula that worked.
Put the Photon into Listening Mode, and get the ID
Reset to Factory Defaults.
Immediately go into DFU Mode
Flash the Device the your cloud key
Go back into DFU mode and Assign a New Key
Go back into DFU mode and Doctor that key
DO NOT BOOT INTO NORMAL MODE, Go to DFU Mode again and Flash Tinker
AGAIN DO NOT BOOT INTO NORMAL MODE go to Safe Mode

The photon will get angry and flash Cyan/Orange but will reboot or flash cyan and reconnect to the cloud and…

You are done it.

Notes: Particle CLI 1.12 with Node 0.10 NOT 4.XX! Upgrading to 4.XX just broke everything and I had to rip everything out of the registry, redo environmental variables, wipe system files and fool around with git unsuccessfully till Particle reverted the Git version (Thank you, if you didn’t do this I wouldn’t have been able to continue trying things…)
Windows 7X64 Pro, Node (32bit) and Openssl (32bit)

The process for number 2 was a little different, but the steps were out of order since I had been trying to get that Photon Working since Early 2015, but it was mainly the same process.

Number 3 and 4 I can’t tell what happened to them, but upgraded firmware and flashes dont seem to bring them back to life, but that isn’t related to this thread so that will go elseware. Only 1 to my knowledge was doing the cyan/red flash.

When I try this it says “Please specify a key in DER format”

I’m having the same problem. I don’t know how or when but the device got a new WiFi ID, so I assumed it had a different key or whatever.

I did the keys doctor, which was a success according to node.js, however the device still blinks blue and then bursts red. I’ve redone a setup, I’ve reregistered keys, I’ve deleted WiFi credentials and installed new ones but simply nothing happens.

The device doesn’t connect, the device does nothing actually. When I first encountered this problem, it just booted into listening mode (as if it came fresh from the factory). The device was already registered and used prior this week, no problems at all.

What can I do now? :frowning:

I’ve done this as well, successfully according to node.js, but still my Photon blinks blue and then bursts red.

Try particle update and particle flash --USB tinker both in DFU mode. That might help :slight_smile:

Unfortunately, it did not :confused:

Still cyan blinks with burst red.

To address @kennethlimcp I used particle serial identify to find the device ID. It does give me a serial error, opening COM6 access denied. Anyway, after that I put the device into DFU mode (yellow blinks) and ran particle keys doctor device_id. The command prompt returns that it has completed this successfully:

attempting a new public key for device dev_id
submitting public key succeeded!
Okay! New keys in place, your device should restart.

And then it still blinks cyan with red bursts. Doing a setup with particle setup, setting the credentials with particle serial wifi or using my phone to claim the device all result in nothing… The setup via phone fails at verify device ownership.

This device worked yesterday, even this morning. I had it in my account but already unclaimed it to use my phone to set it up (which most of the times is much faster than looking up how to do it over serial again ;))

Anyway, the device is still stuck :frowning:

I suppose you have replaced dev_id with your actual device ID.

You may also want to shoot this after particle keys doctor <yourDeviceID>

particle keys server

And make sure your CLI is 1.16.0 (or newer)

2 Likes

Whoah! :open_mouth: That did it! :smiley:

Device is connected, back in my dashboard as well and uploading is going great again.

Many thanks :smile:

2 Likes

5 posts were split to a new topic: Flashing Cyan

Hey @omarojo – your most recent post is a bit different than the original topic, “Photon setup flashing cyan with a “quick red burst” (now orange burst)”, so I am going to move it into a new post with the title, “Flashing Cyan”.

Thanks!

1 Like

Hi guys, having a nightmare here with a soldered in photon flashing cyan/red…

Tried everything in this article (with an updated CLI):

 - particle keys server cloud_public.der
 - particle keys new
 - photon particle keys load photon.der 
 - particle keys send 430032000F51353338363333 photon.pub.pem 
 - particle keys doctor 430032000F51353338363333 
 - particle keys server 
 - particle update
 - particle flash --usb tinker

Still no luck :pensive:.
I can see the system firmware is 0.5.3 and when I try the command:

 - particle device add 430032000F51353338363333

I get: Failed to claim device, server said: [object Object]

Can someone help? @BDub can you try provisioning a new key like you did before?

Can you post the output of these commands?

(in Listening Mode blinking blue)

particle identify

(in DFU Mode blinking yellow)

particle keys server
particle keys doctor 430032000F51353338363333

And also a video of the blinking LED to see what exactly we are up against?

Having a look at the output of particle update wouldn’t hurt either.

1 Like