Photon set up keeps failing

Hello all, I’ve been coming across a problem when I’ve been trying to set up my Photon but the verifying device ownership keeps failing. I’ve tried multiple times on the app setting it up to see if it’d work, but the same stage keeps causing an error. Is there any way to solve this?

Thanks,
Jacob

Have you tried setup.particle.io?

Yes, but it freezes on Step 2. When I try setting it up through USB with the Particle CLI, I get this error:

(node:5772) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): ReferenceError: when is not defined

I’ve also tried using the command particle serial wifi, but the photon goes to the stage where it’s trying to connect to the cloud and doesn’t advance from there. Any suggestions?

Thanks,
Jacob

I would probably send a ticket to hello@particle.io, but first, let’s get someone more experienced than me in here. @Moors7, @ScruffR

What does that mean?
What does the RGB LED do?
If it won’t reach breathing cyan, can you post a video?
Are you using WEP or WPA/WPA2 in your network?
Does your network satisfy the prerequisites?
Is your firewall setup to allow CoAP to pass (port 5683)?

1 Like