Photon not reacting


I have a Photon that seems impossible to reach. I can not put it into listening mode (hold setup for 3 secs, waiting for blue)… I CAN put it into safe mode (hold setup and reset, release reset, continue holding setup until blinking yellow)…

I have tried the “particle device doctor” command in the CLI, and it works until I select a wifi, then I get this:

> Detected WPA(PSK/AES/AES) security
! Something went wrong: Error: Error: No such file or directory, cannot open /dev/tty.usbmodem12
The Doctor didn't complete sucesfully. Error: No such file or directory, cannot open /dev/tty.usbmodem12
> Please visit our community forums for help with this error:
Potentially unhandled rejection [4] Error: Error: No such file or directory, cannot open /dev/tty.usbmodem12

When I try a normal “particle setup”, it now finds the Photon, but it fails when trying to connect wirelessly.

Any hints as to what to try?


Have you tried putting the device into Safe Mode first and then from there activate Listening Mode?
Does it breathe cyan when starting up normal?
If the device is breathing cyan but is hard to reach then the most likely reason for that is the currently running code starving the cloud process from processing time.

When it boots up now, it breathes white (Wifi off, as far as I understand).

I can’t activate Listening Mode, even if I’m in Safe Mode first. It just continues blinking yellow.

What is the most ‘factory reset’-type thing I can try? When putting in Safe Mode and connecting via USB - what should I call in the CLI. I’ve tried particle setup, particle update (even though it should be updated) and particle device doctor (which gives me the error from the first post)…

Safe Mode is not blinking yellow. Safe Mode would be breathing magenta.
Blinking yellow is DFU Mode.

Aaah, sorry, my bad!

I can not enter Safe Mode. When I hold setup+reset, let go of reset, wait for magenta-blinking, let go of setup, the LED seems to quickly fade down from full white to a quick red, and then resume the ‘white breathing’…

If only holding down only Setup for 3 seconds, the LED lights blue for half a second, turns of, starts blinking magenta… If letting go it goes back to breathing white.

If holding down only Setup for more than about 5 seconds, the same happens, but then it blinks yellow. Letting go it keeps blinking yellow.

Does this sound familiar to anyone? Any advice on how to proceed?


Can you post a video of the attempt to enter Safe Mode (at least 30sec)?

Here’s a video of my trying to enter Safe Mode and Listening mode… (I hope. :slight_smile: )

1 Like

That is no normal behaviour.
You can try downloading the system and bootloader binaries and flash them in DFU Mode

particle flash --usb system-part1-0.7.0-photon.bin
particle flash --usb system-part2-0.7.0-photon.bin
particle flash --usb tinker

Then you can try to enter Listening Mode again (hold SETUP for 10+ seconds)
If you can enter LM flash the bootloader

particle flash --serial bootloader-0.7.0-photon.bin
1 Like

Thanks… I was able to get a Flash Success on the system-part1 and system-part2 (I’m guessing it should be 2 and not 1 again) and also tinker. But then this happened:

This seems to be something more severe then.
You may need to open a support ticket with a reference to this thread.