Photon Not connecting


I had a long post over several days to get my new photons to work with my wifi. The solution was to update the firmware However, I took the Photon to another wifi and I am now getting this error:

I tried doing as suggested - still get the same error.

Can someone provide some background as to what the cause is here?

Thank you.


the quick solution now would be to send in the Wifi credentials via USB.

Reading between the lines (I don’t know for sure) but it could be that the Mobile is reacting to the device staying in setup mode (blinking blue.) This can happen when the Wi-Fi password is incorrect. Please double check the password and try again!

I now have a different issue:

I am back on the original wifi network. I had initial issues get any photons to work. Your suggestion to upgrade the firmware did the trick. I can now set the wifi from the app or via usb. I unplug the photon and plug in again and it will not reconnect - flashing green. I then reset using the app or usb, unplug, same result - it is as if it is not storing the wifi credentials. Any ideas?

Thank you

Several people are seeing this issue, but I’m not yet able to reproduce it. The WiFi creds are not actually lost, it’s just that the device doesn’t connect. See this thread WiFi credentials lost after flashing new user firmware (photon). Please give details of your router, and other setup in that thread. Thanks!

Please also describe any changes between now and the time it was working on your original wifi network.