Photon listed as a Product 3780 in 「particle list」 [SOLVED]

I have a few of Photons.
And I used the command “particle setup” to add device into my account.

However, one Photon can’t add with “particle setup”, it need to add in Particle IDE ( manually.

And I used the command “particle list” to receive the information of devices, as follows:
$ particle list
C01 [54XXXXXX66675151XXXXXX67] (Core) is offline
C02 [54XXXXXX66675151XXXXXX67] (Core) is offline
P04 [30XXXXXX12473532XXXXXX33] (Photon) is offline
P05 [35XXXXXX15473532XXXXXX33] (Photon) is offline
P06 [3eXXXXXX17473532XXXXXX33] (Photon) is offline
P07 [36XXXXXX12473532XXXXXX33] (Photon) is offline
R01 [23XXXXXX0c473530XXXXXX37] (Product 88) is offline <---- RedBear Duo, looks right.
P01 [28XXXXXX11473532XXXXXX35] (Photon) is online
P02 [2eXXXXXX05473531XXXXXX38] (Photon) is online
P03 [24XXXXXX01473531XXXXXX38] (Product 3780) is onlineXXXXXX <---- It should be Photon, not Product 3780

In addition, the type of this device in the Particle IDE is show as ‘Other’, not ‘Photon’.

How can I solve this problem?

Have you ever tried to flash some code that contained the line?


e.g. while testing someone elses code that contained that line

Thank you for your reply.
I have never flash the code.

However, I have solved this problem.
In two days ago, I have created a new product, namely test-1111, and it’s id is 3780.
And I forgot what I already had add the P03 device in this product.

I remove the P03 from the list of Product 3780.

Now, it shown in the particle list command correctly.

1 Like