Photon flashing cyan and blinking orange

How do I do this? I tried Holding both buttons and releasing the reset button, the releasing the setup button when is flashes magenta. It goes white for a second, then back to what it was doing before. I cant seem to get it breathing magenta.

Weird… Can you place it in DFU mode and run particle flash --usb tinker and see if it works?

Were they any error when performing the keys command?

Here’s what happened while running the particle keys doctor command:

**particle serial identify**

Your device id is <>
Your system firmware version is 0.4.9

**particle keys doctor 3e003a001347343338333633**
running dfu-util -l
Found DFU device 2b04:d006
running dfu-util -l
Found DFU device 2b04:d006
running openssl genrsa -out 3e003a001347343338333633_rsa_new.pem 1024
running openssl rsa -in 3e003a001347343338333633_rsa_new.pem -pubout -out 3e003
running openssl rsa -in 3e003a001347343338333633_rsa_new.pem -outform DER -out
New Key Created!
running dfu-util -l
Found DFU device 2b04:d006
This file already exists, please specify a different file, or use the --force f
checking file 3e003a0013433633_rsa_new.der
spawning dfu-util -d 2b04:d006 -a 1 -i 0 -s 34:leave -D 3e003a001333363
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #1 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash   "
Downloading to address = 0x00000022, size = 610
Download        [=========================] 100%          610 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
running openssl rsa -inform PEM -in -p
bout -outform PEM -out C:\Users\akato\AppData\Local\Temp\116228-6304-1ndk1ln.pu
running openssl rsa -pubin -inform PEM -in
pem -pubout -outform PEM -out C:\Users\akato\AppData\Local\Temp\116228-6304-1nd
attempting to add a new public key for device 3e003a00134734
submitting public key succeeded!
Okay!  New keys in place, your device should restart.

I ran particle flash --usb tinker in DFU mode and it seemed to work successfully, but I see no change.

Can you delete the previously created key files in the directory and try again? or you can use particle keys doctor deviceID_HERE --force

Ran particle keys doctor device_ID --force and it is now back to the same cycle

Any Ideas?

@Ak4, no clue what’s going on with your device. Has it been claimed before? Can you show a video of the led light sequence?

Its been claimed. Heres the cycle it keeps repeating:

That is not the red/orange burst but this error (is it orange or red?)

1 Like

Definitely Orange. Will flash orange 3 times in between cyan and green flashing. Sometimes a few minutes go by before I see the orange again.

Never seen a pattern like that with orange. It looks more like unable to connect to the :cloud: successfully.

Can you setup a mobile hotspot, configure the photon to use that and see if connection is successful?

My phone wont connect. Goes through the motions but gives me an error message that says “Setup process couldn’t configure the Wi-Fi credentials for your photon, please try running setup again after resetting your Photon and…”

What i meant is to setup a mobile hotspot using your phone and configure your Photon to connect to the hotspot that has been created to see if it connects successfully.

I don’t have the ability to do this on my phone. In the meantime, I tried factory resetting. Now my photon is flashing green, and my computer can’t recognize the serial connection.

Issue mysteriously resolved itself. I still have absolutely no idea why.

My electron is now doing the same cycle with the orange blinks. Tried a firmware upate, tried key doctor, tried deactivating and reactivating SIM, read a bunch of other posts. Still unclear why it is doing this.

For green blinking, followed by cyan blinking, then red/orange blinks you should do both of these with the Photon/Electron in DFU mode (blinking yellow):

particle keys doctor <deviceid>
particle keys server

It’s possible for a corrupted server key to cause the problem as well as a problem with device keys; the particle keys server command with no additional parameters will reset the server key for your device.

That did it, the particle keys server is what I was missing.

This worked for me (had blinking cyan with orange/red outbursts) - Thank you!!


This topic was automatically closed after 4 days. New replies are no longer allowed.