Photon doesn't power up/no LED response

I just received my Photon, and when I plug it in, I get no LED response. Not the main LED or the D7. I tried two USB ports on my Mac, and with a power supply. Tried three different cables.

Is it still in the protective foam it came in? If so, could you take that off, since it’s conducting. I doubt that’s the cause, but it doesn’t hurt to check.
Has it ever lit up? Does your computer detect a new device when you connect it?

Nope, it’s not in the foam. Tried it on its own first, then plugged into a breadboard. It never lit up and my computer doesn’t detect it.

Hold the SETUP button before plugging in the USB cable. Does the LED light up?

What about tapping lightly (LIGHTLY!) on the metal cover in the center or inspecting it for a dent or ding?

Thanks for the suggestions!

Holding the SETUP button before plugging in the USB cable didn’t help, unfortunately.

Lightly tapping the metal cover didn’t help either. I’m looking at the cover, and it looks like there could possibly be a tiny ding near the edge? But I’m not sure, it’s super, super tiny if it’s there at all.

I will Ping @kmmonk and see what can be done.

Thank you.

I see from the Troubleshooting questions on the Support page, the company generally suspects hardware shorts in this circumstance. I guess I will contact directly for a new Photon or refund.

Hi all, hate to hijack.
I have the exact same issue with my Photon - the thing is that it was working fine when I last used it around 3 months ago; it’s just been in storage since. I know that components in switch mode power supplies can go bad if left unpowered for several months - is it possible that the onboard regulator may have failed? I have another Photon to test against and the cable and USB port are both fine.

I’ve just noticed that the metal plate is moderately warm after leaving it plugged in for a few minutes - this is pretty standard from what I recall. So possibly it is getting power then? I’ve tried the two things mentioned above btw, to no avail.

My photon was stored away for a while, and when I plug it in, the main LED does not light up. When holding the setup button and plugging it in, the D7 pin lights up for a moment and then goes off. What should I do?

Weird… do you have a programmer shield or stlinkV2?