Photon Cannot Connect to Wifi after Several Days

I’ve installed a Photon on a client site, ensured it connected to wifi, and ran it for one day before the internet connection gave out. The device tried to find a wifi connection (it was still available, PCs could connect to it) but remained on a flashing green status LED.

Shipped down a second micro controller, connected to the wifi, but after three days it started the same pattern going into flashing green LED mode.

The wifi is 2.5GHz, channel 1. Photon is powered by USB on a surge protector. The circuit is wired to drive a WS2812B array of LEDs. Using the Particle Cloud API to send commands, with a delay on requests so we don’t trigger an API limit (it’s currently set to 5s intervals at peak). I’ve ensured that both Photons are running on the latest firmware.

I understand that the Photon is 5V tolerant, but wanted to rule out that as an issue. If I unplug the LEDs I continue to have the same issue.

Any help is appreciated, would love to be able to solve this without sending down a third device.

You probably meant 2.4GHz?

What happens when they power cycle the device? Does it fail to connect?

Yes 2.4GHz, sorry. When we power cycle the device it returns to the flashing green.

Could it be a (limited) DHCP lease time on the router?

1 Like

I’m checking that with the technician on site. But wouldn’t the lease just be renewed after it expires?

Quick update on this, we flashed the device and it worked again for three days. It’s now offline again. I’ve got a second Photon on site and it is exhibiting the same behaviour. Now shipping down an Arduino with an Ethernet shield as a replacement. DHCP lease time is set to 3 weeks.

@eightlines, I wonder if the issue is hardware related since both Photons failed in the same way. Or possibly a code issue. I have seen situations where USB power supplies will degrade over time as they get hot and since you are driving an array of WS2812Bs, there may be the right conditions. Can you share you hardware configuration?

I’ve had a Photon driving a 4 meter string of WS2812s directly (no level shifter) using a high quality 5v 3A supply directly powering the Photon via Vin. I also use decoupling caps near Vin to reduce noise. This works very reliably.

@eightlines what is the led status?

Also, what is the system firmware that you are compiling against?

Can you get them to place the failed devices in safe mode and see if it connects properly?

Maybe you can setup at your own desk and see if the same symptom exhibits itself.

I would also recommend this for testing:

1 Like