Photon breathing red and cyan


I recently bought a couple of Photons and updated them with particle update. This worked fine.

I flashed it with my firmware a few times and then started working somewhere where the WiFi signal was weak. I think one of the flashes failed.

I tried a hard reset (I used the Core before so I didn’t know about safe mode) and after that my issue started.

When I boot up the photon, it starts blinking green and then goes to blue like normal when connecting to WiFi. When it should start breathing cyan, it instead breathes cyan and red.

I tried to do a hard reset again but now it will only go to DFU mode no matter how long I hold in the button.

I’ve tried doing particle update as well downloading the newest firmware and running the commands.

Is this thing completely bricked or is there something I can do?

I also just tried flashing a backup Photon I have and it would look like it was flashing but never actually update the firmware

Hey @jlkalberer,

maybe you can try the steps here: Photon Troubleshooting Guide (as of Firmware v0.4.6)

Hey, I just got both of my Photons back into a good state by doing:

particle update
particle flash <name> tinker

I still can’t update the cores via Particle dev.

I even tried flashing an empty program:

#include "application.h"

void setup(void) {

    while(!Serial.Available()) {

void loop(void) {}

What do you mean with update the Cores?
Each time you flash your code you get the application firmware and the system firmware delivered.
If you built the app fw with 0.4.5 your Core will be 0.4.5

Ok, I didn’t do anything different this morning but I got original Photon to flash. I was going to make a video of what the LED was doing but it seems to be working now.

I’ll post here again if I can reproduce this.

Thanks everyone