Photon breathing cyan but can't flash any firmware, even after factory reset

When I flash firmware from build.particle it appears successful, however the particle never blinks magenta. Looking at the dashboard logs I see the device go online when I plug it in, and go offline shortly after I initiate the firmware flash. This has persisted despite several factor resets. Any ideas?

I have had issues with my photon resetting and doing strange things as well. After a while, a few resets, power cycles and waiting, mine usually comes back online. I think there seems to be some bugs that need to be worked out with the Photon as my Core has been online for months and have never noticed any random resets and going offline, or issues with flashing. My hope is the new update will solve some of these issues. I have found reset, patience, and a bit of cursing seems to cure it after a while.

Have you been able to flash it at all? I have also found using the mobile app, flashing tinker to it, then after that is successful, I push my code and it works.

Has it come online for you at all? Did it ever work? Is this something that happened since you received it or something that just started?

Also have you tried flashing it using another method. I know its not ideal but could be something worth trying Check out this post Flashing Photon without internet

@devights and @valleyapps, there is a pinned topic
AVOID factory reset - What to do with unexpected LED behavior on a Photon
and a hint in the docs to use Safe Mode which prevents your application code from interfering with OTA flashing and usually helps to overcome this kind of trouble.


Safe mode seemed to do it, thankfully I didn’t end up bricking the photon. Thanks!!