Photon blinking green

Continuing the discussion from: [Spark core] Common issues

@ladysarakat Sorry for the frustration that it worked and stopped doing so after. I wished i had more insights into why this is happening.

Do you have particle-CLI installed?

@kennethlimcp Yes, I do. Particle list sees it (and the name couldn’t be more accurate… named after it’s 4 character identifier PHOTON-PEMP):

Sara$ particle list
PEMPin_aint_easy [2c0043000447343233323032] (Photon) is offline

Particle serial wifi, however, times out (I’ve left out the part that shows my SSID and password).

Attempting to configure Wi-Fi on /dev/cu.usbmodem1421
I said: w
timed out on SSID:
Something went wrong Serial prompt timed out - Please try restarting your device

Do you have suggestions as to what I should try? I appreciate the advice!

Can you do a particle update with the Photon in DFU mode (blinking yellow) and try particle serial wifi again?

I’ve had it unplugged since my last post… Plugged it in, it connected and is working seemingly just fine…

I have not made any changes since I shelved it due to it not working. Is there some sort of on board capacitor that requires a full discharge in order to fully reset? This same thing happened when I first got it: it wouldn’t connect/solid white/blinking green, then I left it off for a few days, then it magically worked immediately after plugging it back in. When I unplugged it and later the same day plugged it back in to show my husband, it wouldn’t connect any more. Now that I’ve left it off for a day, it works again.

I’ll play with it again today and see if I can repeat that cycle. I am not counting on “me plugging it in and it working” as the permanent fix…

To answer your question - while it was in it’s Not Connecting phase, I did particle update probably 5 times and tried particle serial wifi many times over the course of troubleshooting. Sometimes it would lock in blinking green and I wouldn’t be able to get it into any other mode other than DFU, and updating it via particle update was the only way to get it back to Listening.

1 Like

Ok, it’s been unplugged for over a week and we have a blinking green and it won’t connect. I’ve done a particle update. I’m not sure what to do now - this is really frustrating at this point. Am I doing something wrong?

@ladysarakat, can you do this:

  • npm update -g particle-cli
  • place Photon in DFU-mode
  • particle update
  • place Photon in DFU-mode
  • particle flash --usb tinker
  • hold on to the SETUP button until the device blinks blue
  • release SETUP button and press and hold until it blinks blue rapidly to clear wifi credentials
  • particle serial wifi to setup Wifi credentials

Let me know how it goes. Sorry about that! We can arrange for RMA if it really doesn’t work :slight_smile:

2 Likes

Can confirm similar issues to those raised in this thread.

I have seen this with Photons when we are developing on multiple different WiFi access points. There seems to be a chicken-egg if you have joined it previously to a WiFi that it can no longer see. It flashes green trying to connect, and if you hold down the Setup button, the light goes off entirely rather than flashing blue. It does seem to eventually take the WiFi setup via particle serial wifi, but it seems much more finicky during this period.

Following @kennethlimcp’s instructions and flashing everything to latest doesn’t seem to resolve it.

FWIW, if you have breathing cyan, it happily goes into listen mode when holding the Setup button.

1 Like

We’re going to look at the “slow to enter listning mode” issue for the 0.4.6 release. We need to find a way to stop the WICED library from trying to connect to WiFi. We’ve already taken steps in this direction, but seems we need to do more!

Just wanted to say I was having the same problems and @kennethlimcp’s solution worked for me.

Ok, so my photon is blinking green. It cant connect to the wifi - got it.

Here’s the trouble, though, I had it connected to my wifi at home, and I have managed to flash programs to it - everything was working great. I have written this cool program that generates a maze, and then lets you navigate through it using a 3-axis accelerometer as input and a 5x7 led display to render the local area of the maze you are in. I even have the RBG on board showing some indication of how far you are away from the exit as the crow flys. Nifty stuff.

Unfortunately, as I was messing around with the photon board, plugging in the usb cable, I managed to break some or all of the usb contacts with the photon. I can no longer power it over usb. Not to be dismayed I hooked up dc adapter and a 7805 and a couple of caps to make a quick power supply and hooked that to the phonon’s gnd and vin pins. It works like a charm. At home, where it is talking to my wifi.

When I took the board to work this morning, hoping to show off and brag to my coworkers about how awesome my toy is, I was dismayed to find that I could not get the photon to a point where it would run my code. I could put it into safe mode or listen mode, but neither of those do me much good. The usb connector is broken, so I cant talk to it over the serial line to get it hooked up to the office wifi, and safe mode does the wrong thing for this case.

Is there a way I can show off my toy away from my home wifi short of attempting attach a new connector to the board?

1 Like

You can attempt to connect to your mobile hotspot and test that it is working fine before moving to the office.

Wifi networks in office setting in general has some restriction for ports so that might be the reason why it is unable to connect to the :cloud:

Well, how can I tell it what the SSID and Password for my mobile hotspot is?

It depends on what did you configure it to be for your phone?

having same problem and it is caused by wifi ssid.

  • connected to ssid one
  • everything ok
  • moved home with ssid home, particle blinking green
  • just turned tethering on mobile with ssid one - everyting OK

also particle is reluctant to turning dfu mode on on both ssids

Hi,
I am trying to resolve this issue on a linux box (no CLI). Photon worked fine when I connected to WiFi at the lab using the web interface. I am now trying to program the board locally via USB at home, but running into the blinking green LED problem. In which file should I input the wifi credentials when I change locations, so that I don’t keep running into this issue?
I tried using the WiFi.listen()/setCredentials() and other commands in my application, but it does not seem to do anything.
I would like to know if you were able to resolve this issue.

Thanks,

Rakesh

I’ve also been marred with this issue on two new Photons that I just started working with (they were part of the first batch sold, did FW update). I’ve been using Spark Core before and although it had some similar issues as well, at least for now the Photons I have seem much more unreliable…

edit: updated my old Core to the newest firmware, and now it exhibits the same erratic behavior. I can connect it once to my WLAN, see it on the cloud etc. but after a while it always goes to either breathing green or blinking green… very frustrating.

Only one question did somebody found a solution for that?
I have the same situation. After switching between different wlans the photon will only blink green.

I would like to reuse it but at the moment I didn’t find any solution to bring it back to normal work.

Did somebody has an idea?

Thanks
Ralf

Have you tried all of the above?

My first step would be to clear the stored credentials (while blinking green, press & hold SETUP for 10+ sec till rapid blue flashing) and then reenter the credentials of your currently available network.

I have four stored networks and moving from one to any other and back is no issue for me, it just takes a while if the desired network is last in my list.

1 Like

I tried the following steps.
Pressed the Button for about 10+ sec. Blue flashing fast.
particle serial wifi
Entered the credentials.

Directly after entering the wpa2 it flashes green. The mentioned reboot will not be performed.
After an time the photon then switch back to slow blinking blue.

Did you have an idea?
I also performed the steps above. But this does changed the behavior.

1 Like

So you don’t even get the prompt for either the WLAN cipher or the password?
That’s odd.
You have got CLI v1.14.2, right?

Could you try the oldfashioned way via a serial terminal and entering w?


Also you never had used WiFi.selectAntenna() to choose the external antenna and not got it connected now? (just checking ;-))