Particle Workbench hosed my Photon

Tried to use Particle Workbench to flash my Photon. The laptop crashed halfway through. Now, when using Webbuild, to try to flash it, I get a message that says modules needed to flash are not on the device.

Any ideas on how to fix it, or is time to shell out another $29.00?

Try to go to safe mode then flash with Tinker then flash with your app

Thanks for the suggestion.
I tried that. It didn’t work.

(Edit: realized it sounded harsh)

Would be good to get a more specific problem description.
What does the Photon do?
What does particle serial inspect (in Listening Mode) tell you about the device?
Have you tried particle update -v (in DFU Mode)?

BTW, the topic title does come across click-baity. Your Laptop crashing probably was the reason, that Workbench caused that crash is not that likely tho’

The laptop crashing is undoubtedly what caused the problem, but I think it crashed because of Workbench. I wish I had stayed with Webbuild, but it’s file management sucks.

I tried running Particle Doctor and got the following response.

Your device is ready for a system update.
This process should take about 30 seconds. Here it goes!

! An error occurred while attempting to update the system firmware of your device:

File too short for DFU suffix
A valid DFU suffix will be required in a future dfu-util release!!!
Error during download get_status

Please visit our community forums for help with this error:
https://community.particle.io/
The Doctor didn’t complete successfully. Cannot read property ‘code’ of undefined
Please visit our community forums for help with this error:
https://community.particle.io/

I hope it’s not totally fried.

Try this out. I used search feature :slight_smile:

2 Likes

Thanks dreamER. You fixed my problem.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.