Particle Photon Won't connect to cloud

I have a particle photon that was working great until December 2017 when the power supply failed and it’s been off line ever since. I replaced the power supply today, but it wouldn’t connect to the cloud. It flashed green, then cyan, indicating it connected to the WiFi, but didn’t connect to the cloud. Initially it flashes cyan a few times, then red once, and repeats this pattern a few times, then just flashed cyan continuously.

I have tried running particle setup again, from my phone, from my Mac Book over Wifi and using the CLI. Same result each time.

I tired running particle device doctor from the CLI, but all I get is the following:

Jamess-MacBook-Pro:~ jim$ particle device doctor
particle device doctor

Jamess-MacBook-Pro:~ jim$

I tried running particle setup from the CLI again after this, and it runs through the wifi set up, but does not connect to the cloud. I have triple checked the Wifi settings, and set up another photon with them successfully.

Is there anything else I can try is it time to buy a new photon?


Double check that you are on most recent CLI (currently 1.34.0) and then run

particle flash --usb tinker
particle update
particle keys doctor <youDeviceID>
particle keys server

(all in DFU Mode)
Clear the WiFi credentials and reapply them.

If this still doesn’t help, put the device in Listening Mode, exectue particle serial inspect and post the output here.

1 Like

That worked - it’s back!

Thanks very much.

1 Like